summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-24 17:26:01 +0000
committerSam James <sam@gentoo.org>2021-01-24 17:26:23 +0000
commit9fc16b80337c0218914911807354ca0b84e1f956 (patch)
treebd147646cd1d5da6ac8d3fe0ee928a7221ae170e /dev-ml/cppo
parentdev-ml/ocamlbuild: port to EAPI 7 (diff)
downloadgentoo-9fc16b80337c0218914911807354ca0b84e1f956.tar.gz
gentoo-9fc16b80337c0218914911807354ca0b84e1f956.tar.bz2
gentoo-9fc16b80337c0218914911807354ca0b84e1f956.zip
dev-ml/cppo: port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/cppo')
-rw-r--r--dev-ml/cppo/cppo-1.4.1.ebuild6
-rw-r--r--dev-ml/cppo/cppo-1.5.0.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-ml/cppo/cppo-1.4.1.ebuild b/dev-ml/cppo/cppo-1.4.1.ebuild
index e9730dd44aa4..c01764452e40 100644
--- a/dev-ml/cppo/cppo-1.4.1.ebuild
+++ b/dev-ml/cppo/cppo-1.4.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit findlib
@@ -21,9 +21,11 @@ DEPEND="${RDEPEND}"
src_install() {
findlib_src_preinst
+
mkdir -p "${ED}"/usr/bin
emake PREFIX="${ED}"/usr install
dodoc README.md Changes
+
if use examples ; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
diff --git a/dev-ml/cppo/cppo-1.5.0.ebuild b/dev-ml/cppo/cppo-1.5.0.ebuild
index edc62efc16d9..f6525a761bd7 100644
--- a/dev-ml/cppo/cppo-1.5.0.ebuild
+++ b/dev-ml/cppo/cppo-1.5.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit findlib
@@ -27,9 +27,11 @@ src_compile() {
src_install() {
findlib_src_preinst
+
mkdir -p "${ED}"/usr/bin
emake PREFIX="${ED}"/usr BEST="$(usex ocamlopt '.native' '.byte')" install
dodoc README.md Changes
+
if use examples ; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples