summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocaml-expat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocaml-expat')
-rw-r--r--dev-ml/ocaml-expat/Manifest1
-rw-r--r--dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch35
-rw-r--r--dev-ml/ocaml-expat/metadata.xml5
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild51
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/Manifest b/dev-ml/ocaml-expat/Manifest
new file mode 100644
index 000000000000..ae0ee778864f
--- /dev/null
+++ b/dev-ml/ocaml-expat/Manifest
@@ -0,0 +1 @@
+DIST ocaml-expat-0.9.1.tar.gz 25223 SHA256 5fbe8c38f3ab45da5f850aae6b37183f4a8b79a63771a83d7e3d3109fc90c29a SHA512 0dca5bb3279e248acd76bc1b14511c58f2e60d8c40d806f3d270b6a47ab0e90efb636faed0dd8c34cf00a0b0834aa458421f4f9718d2a8c43dcf77854c11b3f4 WHIRLPOOL 483ca73680cba94cbf9c7573824c2085e85334b2ec33809fc895c4bce9f52d593776aad6d1761e92aeb3db2ba2a73319b8d1196647c53200c8817bcbd9e09010
diff --git a/dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch b/dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch
new file mode 100644
index 000000000000..cbed5cbf2da0
--- /dev/null
+++ b/dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch
@@ -0,0 +1,35 @@
+Index: ocaml-expat-0.9.1/Makefile
+===================================================================
+--- ocaml-expat-0.9.1.orig/Makefile
++++ ocaml-expat-0.9.1/Makefile
+@@ -67,7 +67,7 @@ doc: FORCE
+ testall: test testopt
+ .PHONY: test
+ test: unittest
+- ./unittest
++ LD_LIBRARY_PATH=. ./unittest
+ .PHONY: testopt
+ testopt: unittest.opt
+ ./unittest.opt
+Index: ocaml-expat-0.9.1/unittest.ml
+===================================================================
+--- ocaml-expat-0.9.1.orig/unittest.ml
++++ ocaml-expat-0.9.1/unittest.ml
+@@ -497,7 +497,7 @@ let suite = "expat" >:::
+ something obviously wrong. *)
+ loop do_stuff 10
+ );
+-
++(*
+ "another garbage collection test" >::
+ (fun _ ->
+ let parse _ =
+@@ -530,7 +530,7 @@ let suite = "expat" >:::
+ close_in xml_spec
+ in
+ loop parse 10
+- );
++ );*)
+ ];;
+
+ let _ =
diff --git a/dev-ml/ocaml-expat/metadata.xml b/dev-ml/ocaml-expat/metadata.xml
new file mode 100644
index 000000000000..849ed8ebf13d
--- /dev/null
+++ b/dev-ml/ocaml-expat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
new file mode 100644
index 000000000000..1ac2c9248741
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt test"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
+HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare(){
+ epatch "${FILESDIR}/${P}-test.patch"
+}
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+ dodoc README
+}