summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-11 10:43:19 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-11 10:43:34 +0100
commite5c51e8d76fcba9e76903da984c97b01c8c52294 (patch)
treee5dcb4c5bc68886ea096f787ec21a32dd9202c0e /dev-ml/ocaml-expat
parentsys-power/switcheroo-control: stabilize 2.6-r2 for amd64 (diff)
downloadgentoo-e5c51e8d76fcba9e76903da984c97b01c8c52294.tar.gz
gentoo-e5c51e8d76fcba9e76903da984c97b01c8c52294.tar.bz2
gentoo-e5c51e8d76fcba9e76903da984c97b01c8c52294.zip
dev-ml/ocaml-expat: add 1.3.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-expat')
-rw-r--r--dev-ml/ocaml-expat/Manifest1
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-1.3.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/Manifest b/dev-ml/ocaml-expat/Manifest
index 26d8c2c4c49e..77ffcd4e2dec 100644
--- a/dev-ml/ocaml-expat/Manifest
+++ b/dev-ml/ocaml-expat/Manifest
@@ -1 +1,2 @@
DIST ocaml-expat-1.1.0.tar.gz 58318 BLAKE2B 137bc65c5c867180ba547de17041bd0f588da395928e92eabef45cdbb76a1d139d7cd0d80d33337e1fbff92c9fa3cab2339c0f340f50f467b8fe7d64cba10b1e SHA512 9407f91f5007d6835643719294d4e4907bfc40464d054911591ce80c31d173ddcc7b06157a19c0d3ddd78775806242dc68aea7847e588ca9fd1909def1df4d23
+DIST ocaml-expat-1.3.0.tar.gz 58331 BLAKE2B 4d56dd1354a31095afada7e4b0ccc9d1eb7fae4ed45f579d6b2eeb9366df7c0f5ae58680d4e917185bbce2e5e7c957f266cb4e89b7eb1e943f0fb9f68c28f94d SHA512 72a59c982179ebc2cbd4c0659ec81c1c7422de78f9fff4bd9feebda8739d3a50d2840bb5f058e075dd63a2d1af35727e04315361febca3af6c8605ee52e27498
diff --git a/dev-ml/ocaml-expat/ocaml-expat-1.3.0.ebuild b/dev-ml/ocaml-expat/ocaml-expat-1.3.0.ebuild
new file mode 100644
index 000000000000..46144aef7f3f
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-1.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+IUSE="doc +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/whitequark/ocaml-expat"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-4.14.1:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+PATCHES=(
+ "${FILESDIR}/ounit2.patch"
+ "${FILESDIR}/${PN}-1.1.0-cc.patch"
+)
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
+ dodoc README
+}