summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-04 11:24:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-04 12:07:03 +0200
commitc8f8088ab80ce99a83a8a38aebc2d8bd6738e5ca (patch)
treeef007faff8c62f05611b75808754957abb289f3f /dev-ml/ocurl/ocurl-0.7.9.ebuild
parentdev-ml/ocurl: remove old (diff)
downloadgentoo-c8f8088ab80ce99a83a8a38aebc2d8bd6738e5ca.tar.gz
gentoo-c8f8088ab80ce99a83a8a38aebc2d8bd6738e5ca.tar.bz2
gentoo-c8f8088ab80ce99a83a8a38aebc2d8bd6738e5ca.zip
dev-ml/ocurl: bump to 0.7.9
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ml/ocurl/ocurl-0.7.9.ebuild')
-rw-r--r--dev-ml/ocurl/ocurl-0.7.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocurl/ocurl-0.7.9.ebuild b/dev-ml/ocurl/ocurl-0.7.9.ebuild
new file mode 100644
index 000000000000..dc5621bd432f
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.7.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
+LICENSE="MIT"
+SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+IUSE="examples"
+
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ dev-ml/camlp4:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+KEYWORDS="~amd64 ~x86"
+
+src_compile()
+{
+ emake -j1 all
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc CHANGES.txt README.md
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}