summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-15 13:36:13 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-15 17:55:02 +0200
commitd3d1e58e894b4b4674479d91308e2b69cc902625 (patch)
tree9f3389e7576eb6f8e5bfc28b04a127f659d4e923 /dev-ml/ppx_diff
parentdev-ml/gel: new package, add 0.17.0 (diff)
downloadgentoo-d3d1e58e894b4b4674479d91308e2b69cc902625.tar.gz
gentoo-d3d1e58e894b4b4674479d91308e2b69cc902625.tar.bz2
gentoo-d3d1e58e894b4b4674479d91308e2b69cc902625.zip
dev-ml/ppx_diff: new package, add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_diff')
-rw-r--r--dev-ml/ppx_diff/Manifest1
-rw-r--r--dev-ml/ppx_diff/metadata.xml11
-rw-r--r--dev-ml/ppx_diff/ppx_diff-0.17.0.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppx_diff/Manifest b/dev-ml/ppx_diff/Manifest
new file mode 100644
index 000000000000..9e17b2c9512e
--- /dev/null
+++ b/dev-ml/ppx_diff/Manifest
@@ -0,0 +1 @@
+DIST ppx_diff-0.17.0.tar.gz 51242 BLAKE2B 0ff71cade9b94b9a4352958c5d288d910676cc43524bf060b25a0d63ed75ac9b8241ecfeae7f928806269a0fbe961ddc6f60388bd134bc609bebd12971ce13e6 SHA512 63c66108d38e37e1568dd2055e2b90ada633d3a6795144fd9c75cce9dc11edff4df61c19d4845f2b14aae3c732186a7d3b0b7e0591cbfa8c46a440f5c323e6ab
diff --git a/dev-ml/ppx_diff/metadata.xml b/dev-ml/ppx_diff/metadata.xml
new file mode 100644
index 000000000000..3e7a55b51e5b
--- /dev/null
+++ b/dev-ml/ppx_diff/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_diff</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_diff/ppx_diff-0.17.0.ebuild b/dev-ml/ppx_diff/ppx_diff-0.17.0.ebuild
new file mode 100644
index 000000000000..ac5108b1ecd0
--- /dev/null
+++ b/dev-ml/ppx_diff/ppx_diff-0.17.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A PPX rewriter that genreates the implementation of [Ldiffable.S]."
+HOMEPAGE="https://github.com/janestreet/ppx_diff"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/gel:${SLOT}[ocamlopt?]
+ dev-ml/ppx_compare:${SLOT}[ocamlopt?]
+ dev-ml/ppx_enumerate:${SLOT}[ocamlopt?]
+ dev-ml/ppx_jane:${SLOT}[ocamlopt?]
+ dev-ml/ppxlib_jane:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"