summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/xstr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/xstr')
-rw-r--r--dev-ml/xstr/Manifest1
-rw-r--r--dev-ml/xstr/metadata.xml5
-rw-r--r--dev-ml/xstr/xstr-0.2.1.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/xstr/Manifest b/dev-ml/xstr/Manifest
new file mode 100644
index 000000000000..eb5def2fbc16
--- /dev/null
+++ b/dev-ml/xstr/Manifest
@@ -0,0 +1 @@
+DIST xstr-0.2.1.tar.gz 14703 SHA256 796f77589af651d1bb627444fa48c76d887c97d98a58cb95913d86103fb168be SHA512 aeb518353191d48c446641937bbf78660911dd9cbb34689790777fdf47c8ab57640fd0ee04b077a74cbbe46a07bc0ef71062a1b4b7f8a627a9524ef04a03b28e WHIRLPOOL 0fed5397004a02be0e691cd097e8c36dfa5a0ef69bb1ec92f56343985bc44aacbfd68fba744dd87b7687a0deea21cab1092036c9c290af1e12904775d17f5488
diff --git a/dev-ml/xstr/metadata.xml b/dev-ml/xstr/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/xstr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/xstr/xstr-0.2.1.ebuild b/dev-ml/xstr/xstr-0.2.1.ebuild
new file mode 100644
index 000000000000..6967ea122923
--- /dev/null
+++ b/dev-ml/xstr/xstr-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Thread-safe implementation of string searching/matching/splitting"
+HOMEPAGE="http://www.ocaml-programming.de/packages/"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile()
+{
+ make all || die
+ make opt || die
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc README RELEASE
+}