summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-10 20:30:07 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-10 20:30:23 +0200
commit1c3894ba5b91388f249ca1ba45f56b4672534373 (patch)
tree88b0664415d77652e5fe123ff1336f79c8faf1a7 /dev-ml
parentdev-ml/base: limits version of dune-configurator to take (diff)
downloadgentoo-1c3894ba5b91388f249ca1ba45f56b4672534373.tar.gz
gentoo-1c3894ba5b91388f249ca1ba45f56b4672534373.tar.bz2
gentoo-1c3894ba5b91388f249ca1ba45f56b4672534373.zip
dev-ml/ppxlib: add 0.32.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppxlib/Manifest1
-rw-r--r--dev-ml/ppxlib/ppxlib-0.32.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/Manifest b/dev-ml/ppxlib/Manifest
index fe3cd87931e0..4d396cba52b4 100644
--- a/dev-ml/ppxlib/Manifest
+++ b/dev-ml/ppxlib/Manifest
@@ -6,3 +6,4 @@ DIST ppxlib-0.24.0.tar.gz 390297 BLAKE2B 7d8972b766cc8104a4d43aebc79e927e51cba11
DIST ppxlib-0.29.0.tar.gz 572842 BLAKE2B e772cfbbc5ff0390b1d256b7671e51aac0c86fe14e912e42fa6f428958d25af09920deae89ba080e37842f21361494237b697abe48dd563df9f69512a4a110ea SHA512 34babcea63b952ca610b5b9841a7d045e3973870014968d5abfff259de8d0f383e79f799fa3522830e0da5a7ff02fa52764b7cad64c8ac0da5a37f8897314c80
DIST ppxlib-0.29.1.tar.gz 543819 BLAKE2B b0d3920b2aaef887b0120ae66dfa3a0f83d4a4edb237390bddd5206084f77bbd8483d99bc422ce6411a9a1aca7de4fcc5f1f85f9cf46532b7e06c476f2b76b72 SHA512 9bfd52709a63399ff35697b442de6818e2a61b9a2ccf33638f2da6295e3e034e2ae6108a2b8567402e80d928636cdee1572cc14d228a47fbda50625219e411f9
DIST ppxlib-0.30.0.tar.gz 573753 BLAKE2B f16ba3b01288a535ebf7842d8b9379061cc86cb1bad7841540855508d7d9c10c27e63456d68a16a2408a6eee5cffe82c3c0202ad7894b9fabad8194136762e30 SHA512 a7310c5c0fe76c72984bc6a27648bf12ac83222c029b91a7abf8be13f1950f84de4b24e28f2bb50a6a65c16c9a6bb8c4d3d0596c4b5f7f5bedba87f8ca55a810
+DIST ppxlib-0.32.1.tar.gz 610383 BLAKE2B 307b8591eb3d0c5fe44cb4b8361c1196eb84d65fd1613e7e1fc0e6ae51a7572003acb6fb76f273a484d36cd53b5a26d7daaeb8074253fba64024dbf56031a5a4 SHA512 542b49667b3536ac20ddefe0673b833ec728cf0b02ef79da2c98a750bf5ea1293f688134b227638acbbcffd0e5f344ab4ed5b8db6291f1aef096d106fffd0ce9
diff --git a/dev-ml/ppxlib/ppxlib-0.32.1.ebuild b/dev-ml/ppxlib/ppxlib-0.32.1.ebuild
new file mode 100644
index 000000000000..96351ba3ae61
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.32.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+# Note that new "major" versions may change which OCaml version they support
+# See:
+# https://github.com/ocaml-ppx/ppxlib/issues/243
+# https://github.com/ocaml-ppx/ppxlib/issues/232
+
+DESCRIPTION="Base library and tools for ppx rewriters"
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+# It also works with ocaml >= 4 but tests are to be fixed
+RDEPEND="
+ >=dev-lang/ocaml-5:=
+ >=dev-ml/ocaml-compiler-libs-0.17:=[ocamlopt?]
+ dev-ml/ppx_derivers:=[ocamlopt?]
+ dev-ml/sexplib0:0/0.17[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/dune-3.11
+ test? (
+ dev-ml/base:0/0.17
+ dev-ml/cinaps
+ >=dev-ml/findlib-1.9.6[ocamlopt?]
+ dev-ml/re
+ )
+"