summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-19 16:42:11 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-19 16:42:43 +0200
commit79b4922ba1cd281754ec72b261bea0f7c86a9ad1 (patch)
treedfb10ab115db8adc908c73ba9c54227489122c58 /dev-ml
parentsci-astronomy/stellarium: Keyword 24.3 riscv, #941725 (diff)
downloadgentoo-79b4922ba1cd281754ec72b261bea0f7c86a9ad1.tar.gz
gentoo-79b4922ba1cd281754ec72b261bea0f7c86a9ad1.tar.bz2
gentoo-79b4922ba1cd281754ec72b261bea0f7c86a9ad1.zip
dev-ml/reason: add 3.12.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/reason/Manifest1
-rw-r--r--dev-ml/reason/files/reason-3.12.0-fake-git-version.patch13
-rw-r--r--dev-ml/reason/reason-3.12.0.ebuild42
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/reason/Manifest b/dev-ml/reason/Manifest
index db2f1a18f01c..61765c2bf951 100644
--- a/dev-ml/reason/Manifest
+++ b/dev-ml/reason/Manifest
@@ -1 +1,2 @@
DIST reason-3.11.0.tar.gz 699692 BLAKE2B c377e7ccb222ade2f0a5a9b50147a045fb10a95d7e3a8a9ce91674f76a3174ef169f5575ecde7004db2a43350ac8e7cc73315eefcda57b98c9b3d6cc83ed13bd SHA512 71b70e06afbc193c1c4b379c570347e4f971ed001d60e73cf4a745a9bc110e78d329d5ce5334b59aacb7dbe8d2f12f50b7c6786c9a35fff445da0d26f6a87f7d
+DIST reason-3.12.0.tar.gz 661530 BLAKE2B e2855359595f6240055577f4477975cbe4a836801f5db2431d9b243cc583938c401fcdb36a0e8636aa8ee1368f3565625580c10bef679f520a92fb937571b717 SHA512 4258ee4c6bdc20ff3034458e923e58db7da792d8e22a8ab0b281ea2d6bb503cad30356346e255ad9fcac6fbf4e6bf9bf8cacca08b37ece73f3311d9ef821f9f5
diff --git a/dev-ml/reason/files/reason-3.12.0-fake-git-version.patch b/dev-ml/reason/files/reason-3.12.0-fake-git-version.patch
new file mode 100644
index 000000000000..a00a2e063b84
--- /dev/null
+++ b/dev-ml/reason/files/reason-3.12.0-fake-git-version.patch
@@ -0,0 +1,13 @@
+--- a/src/refmt/dune 2024-10-19 14:08:14.370857664 +0200
++++ b/src/refmt/dune 2024-10-19 14:09:03.820258355 +0200
+@@ -10,8 +10,8 @@
+ (with-stdout-to
+ %{targets}
+ (progn
+- (bash "echo let version = \\\"$(git rev-parse --verify HEAD)\\\"")
+- (bash "echo let short_version = \\\"$(git rev-parse --short HEAD)\\\"")))))
++ (bash "echo let version = \\\"0000000000000000000000000000000000000000\\\"")
++ (bash "echo let short_version = \\\"0000000000000000000000000000000000000000\\\"")))))
+
+ (rule
+ (with-stdout-to
diff --git a/dev-ml/reason/reason-3.12.0.ebuild b/dev-ml/reason/reason-3.12.0.ebuild
new file mode 100644
index 000000000000..9bf06edc77e2
--- /dev/null
+++ b/dev-ml/reason/reason-3.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io/
+ https://github.com/reasonml/reason/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/reasonml/${PN}.git"
+else
+ SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/dune-build-info:=[ocamlopt?]
+ dev-ml/fix:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/merlin-extend:=[ocamlopt?]
+ dev-ml/ppx_derivers:=[ocamlopt?]
+ dev-ml/ppxlib:=[ocamlopt?]
+ dev-ml/utop:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fake-git-version.patch" )
+
+src_install() {
+ dune-install reason rtop
+
+ dodoc *.md docs/*.md
+}