summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/CGI
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/CGI')
-rw-r--r--dev-perl/CGI/CGI-3.650.0.ebuild27
-rw-r--r--dev-perl/CGI/CGI-4.200.0.ebuild35
-rw-r--r--dev-perl/CGI/CGI-4.210.0.ebuild35
-rw-r--r--dev-perl/CGI/Manifest3
-rw-r--r--dev-perl/CGI/files/3.47-fcgi.patch24
-rw-r--r--dev-perl/CGI/metadata.xml20
6 files changed, 144 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-3.650.0.ebuild b/dev-perl/CGI/CGI-3.650.0.ebuild
new file mode 100644
index 000000000000..6342bea666c2
--- /dev/null
+++ b/dev-perl/CGI/CGI-3.650.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN}.pm
+MODULE_AUTHOR=MARKSTOS
+MODULE_VERSION=3.65
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-if
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+# dev-perl/FCGI" #236921
+
+SRC_TEST="do"
diff --git a/dev-perl/CGI/CGI-4.200.0.ebuild b/dev-perl/CGI/CGI-4.200.0.ebuild
new file mode 100644
index 000000000000..03d4a64d3515
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.200.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEEJO
+MODULE_VERSION=4.20
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ virtual/perl-File-Temp
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Warn
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/CGI/CGI-4.210.0.ebuild b/dev-perl/CGI/CGI-4.210.0.ebuild
new file mode 100644
index 000000000000..7b7de7827459
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.210.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEEJO
+MODULE_VERSION=4.21
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ virtual/perl-File-Temp
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Warn
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/CGI/Manifest b/dev-perl/CGI/Manifest
new file mode 100644
index 000000000000..4cff2c37489f
--- /dev/null
+++ b/dev-perl/CGI/Manifest
@@ -0,0 +1,3 @@
+DIST CGI-4.20.tar.gz 193964 SHA256 a156ca4c2d780e69daf43f956cb0a5e03513dfb645ebd0253f168aac29ad1be5 SHA512 2721d1df363c5a0ef460ad0c32f072262a302826d8d72d071bc1f8edc2fa6b99dcefaa9fa8f0abbc7d6fd10de57d7f4c6f4f4d23476b1622d5bd5df1bd8e8b12 WHIRLPOOL 58f8f2e7eb4ae145aac7cef9fa78367ef43cd80f92c188cc56aca7cbe45ef9a92fbda7e2c9ff4bd2235f7f6eaecf79ad2e30b07dab8179961e3b01ab8d14423f
+DIST CGI-4.21.tar.gz 194539 SHA256 340d20a2b67211752d7c270c589e463d71aea8b8d75d9417250618219d3cf884 SHA512 cc208b452f59b6fed51442c75ac1634115cbb25a6dfafcdb3e3dbad49a259a450de8abe8abcc66763976f54ae207fbaada5cede550056b5351e0b21a4af707a2 WHIRLPOOL 2656c9ac28eacf16962c0cf9c1efdd8b2988ad72130b3a4a88d60f5dacc112a9df9df018fef1d1fa137203aa4047c0983fd6bb95773d1d40fdef2d200968cb36
+DIST CGI.pm-3.65.tar.gz 247466 SHA256 556d0f9047affa6873da996d8cc077bff797c13f95be89eb771d7247b8f0828a SHA512 b2022b5bf8244be65c1e25394570043585af909947f28a9b0505c0eabca642bd96f58ed90ab2e5c82146192530030cf6b88d4115851dddf3523836c8178ccb8e WHIRLPOOL c6f9251513bd09c78b0785a478047906c47fea82604aa0a64e7943a554e061563d4386fd22a5ba8a83ba98000d19ec82e582fa292c5774443fcefe9b8d98c7bc
diff --git a/dev-perl/CGI/files/3.47-fcgi.patch b/dev-perl/CGI/files/3.47-fcgi.patch
new file mode 100644
index 000000000000..922a577f14b5
--- /dev/null
+++ b/dev-perl/CGI/files/3.47-fcgi.patch
@@ -0,0 +1,24 @@
+http://rt.cpan.org/Public/Bug/Display.html?id=49599
+
+--- CGI.pm-3.47/t/fast.t
++++ CGI.pm-3.47/t/fast.t
+@@ -7,16 +7,16 @@
+ $fcgi = $@ ? 0 : 1;
+ }
+
+-use Test::More tests => 10;
++use Test::More tests => 11;
+
+ # Shut up "used only once" warnings.
+ () = $CGI::Q;
+ () = $CGI::Fast::Ext_Request;
+
+ SKIP: {
+- skip( 'FCGI not installed, cannot continue', 7 ) unless $fcgi;
++ skip( 'FCGI not installed, cannot continue', 11 ) unless $fcgi;
+
+- use CGI::Fast;
++ use_ok( CGI::Fast );
+ ok( my $q = CGI::Fast->new(), 'created new CGI::Fast object' );
+ is( $q, $CGI::Q, 'checking to see if the object was stored properly' );
+ is( $q->param(), (), 'no params' );
diff --git a/dev-perl/CGI/metadata.xml b/dev-perl/CGI/metadata.xml
new file mode 100644
index 000000000000..6c8ef312317c
--- /dev/null
+++ b/dev-perl/CGI/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">CGI</remote-id>
+ <remote-id type="cpan-module">CGI</remote-id>
+ <remote-id type="cpan-module">CGI::Apache</remote-id>
+ <remote-id type="cpan-module">CGI::Carp</remote-id>
+ <remote-id type="cpan-module">CGI::Cookie</remote-id>
+ <remote-id type="cpan-module">CGI::Fast</remote-id>
+ <remote-id type="cpan-module">CGI::Pretty</remote-id>
+ <remote-id type="cpan-module">CGI::Push</remote-id>
+ <remote-id type="cpan-module">CGI::Switch</remote-id>
+ <remote-id type="cpan-module">CGI::Util</remote-id>
+ <remote-id type="cpan-module">CGITempFile</remote-id>
+ <remote-id type="cpan-module">Fh</remote-id>
+ <remote-id type="cpan-module">MultipartBuffer</remote-id>
+ </upstream>
+</pkgmetadata>