summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 04:19:13 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 04:19:13 +1200
commit05ddedd84027b4495dc76929cf1076379d52b4c9 (patch)
treebcd55b0134bff38e99bca117725afaff512b93db /dev-perl/Class-MethodMaker
parentdev-perl/Crypt-DES: -r bump for EAPI7 and fixes (diff)
downloadgentoo-05ddedd84027b4495dc76929cf1076379d52b4c9.tar.gz
gentoo-05ddedd84027b4495dc76929cf1076379d52b4c9.tar.bz2
gentoo-05ddedd84027b4495dc76929cf1076379d52b4c9.zip
dev-perl/Class-MethodMaker: -r bump for CFLAGS love & fixes
- Ensure CFLAGS passed to make - Remove unused eclass 'eutils' Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Class-MethodMaker')
-rw-r--r--dev-perl/Class-MethodMaker/Class-MethodMaker-2.240.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Class-MethodMaker/Class-MethodMaker-2.240.0-r2.ebuild b/dev-perl/Class-MethodMaker/Class-MethodMaker-2.240.0-r2.ebuild
new file mode 100644
index 000000000000..ce5a0cd60c49
--- /dev/null
+++ b/dev-perl/Class-MethodMaker/Class-MethodMaker-2.240.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SCHWIGON
+DIST_VERSION=2.24
+DIST_SECTION="class-methodmaker"
+inherit perl-module
+
+DESCRIPTION="Create generic methods for OO Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}