summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 11:20:13 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 11:21:12 +1200
commit01793cf31060c68d178d5d5e6d26eafcbc30e15b (patch)
treedc556317a714fc4a645da706a4488c7dd77053b1 /dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild
parentprofiles/package.mask: propka 3.2 is py3 package (diff)
downloadgentoo-01793cf31060c68d178d5d5e6d26eafcbc30e15b.tar.gz
gentoo-01793cf31060c68d178d5d5e6d26eafcbc30e15b.tar.bz2
gentoo-01793cf31060c68d178d5d5e6d26eafcbc30e15b.zip
dev-perl/Crypt-DSA: -r bump for EAPI7 and fixes
- EAPI7 - Parallel tests - Improve dependencies to satisfy more tests - Migrate "sed" to "patch" Keywords: - Dropped ~sparc due to new test dependency dev-perl/Convert-PEM Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild b/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild
new file mode 100644
index 000000000000..55bac478b237
--- /dev/null
+++ b/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.17
+inherit perl-module
+
+DESCRIPTION="DSA Signatures and Key Generation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Data-Buffer-0.10.0
+ dev-perl/Digest-SHA1
+ virtual/perl-File-Spec
+ >=dev-perl/File-Which-0.50.0
+ virtual/perl-MIME-Base64
+ >=virtual/perl-Math-BigInt-1.780.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Convert-PEM
+ dev-perl/Math-BigInt-GMP
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.17-no-dot-inc.patch"
+)