summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-14 12:43:09 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-15 10:56:14 -0400
commit27a41e74c71a498b12a474779a5a85eeb1d7455d (patch)
tree5471a148db89d79eaa1bbcecd3ca72d73f4d7656 /dev-perl/DBD-Pg
parentdev-perl/DBD-MariaDB: Drop old versions (diff)
downloadgentoo-27a41e74c71a498b12a474779a5a85eeb1d7455d.tar.gz
gentoo-27a41e74c71a498b12a474779a5a85eeb1d7455d.tar.bz2
gentoo-27a41e74c71a498b12a474779a5a85eeb1d7455d.zip
dev-perl/DBD-Pg: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.15.0.ebuild110
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.16.3.ebuild108
-rw-r--r--dev-perl/DBD-Pg/Manifest2
3 files changed, 0 insertions, 220 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.15.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.15.0.ebuild
deleted file mode 100644
index 75c6fae8ae7d..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.15.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="
- dev-db/postgresql:*
-"
-BDEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? (
- >=virtual/perl-Test-Simple-0.880.0
- virtual/perl-Time-HiRes
- )
-"
-PERL_RM_FILES=(
- "t/00_signature.t"
-)
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
-
-src_compile() {
- mymake=(
- "OPTIMIZE=${CFLAGS}"
- )
- perl-module_src_compile
-}
-
-src_test() {
- local MODULES=(
- "Bundle::DBD::Pg v${PV}"
- "DBD::Pg v${PV}"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1 #||
- #die "Could not load ${dep}"
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
-
- local LIVEDB_TESTS=(
- "t/01connect.t"
- "t/02attribs.t"
- "t/03dbmethod.t"
- "t/03smethod.t"
- "t/04misc.t"
- "t/06bytea.t"
- "t/07copy.t"
- "t/08async.t"
- "t/09arrays.t"
- "t/12placeholders.t"
- "t/20savepoints.t"
- "t/30unicode.t"
- )
- if [[ ! -v DBI_DSN ]]; then
- ewarn "Functional database tests disabled due to lack of configuration."
- ewarn "Please set the following environment variables values pertaining to a"
- ewarn "pre-configured Postgres installation in order for tests to work:"
- ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
- ewarn " ( eg: dbi:Pg:dbname=testdb )"
- ewarn " DBI_USER - A Postgres Database Username"
- ewarn " DBI_PASS - A Postgres Database Password"
- ewarn ""
- ewarn "For details, visit:"
- ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
- perl_rm_files "${LIVEDB_TESTS[@]}"
- fi
- # Parallel testing breaks database access
- DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
-
-}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.16.3.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.16.3.ebuild
deleted file mode 100644
index 82ff3dc5648d..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.16.3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="
- dev-db/postgresql:*
-"
-BDEPEND="
- ${RDEPEND}
- >=virtual/perl-ExtUtils-MakeMaker-6.580.0
- test? (
- virtual/perl-File-Temp
- >=virtual/perl-Test-Simple-0.880.0
- virtual/perl-Time-HiRes
- )
-"
-
-PERL_RM_FILES=(
- "t/00_signature.t"
-)
-
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
-
-src_test() {
- local MODULES=(
- "Bundle::DBD::Pg v${PV}"
- "DBD::Pg v${PV}"
- )
- local failed=()
-
- local dep
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1 #||
- #die "Could not load ${dep}"
- eend $? || failed+=( "$dep" )
- done
-
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
-
- local LIVEDB_TESTS=(
- "t/01connect.t"
- "t/02attribs.t"
- "t/03dbmethod.t"
- "t/03smethod.t"
- "t/04misc.t"
- "t/06bytea.t"
- "t/07copy.t"
- "t/08async.t"
- "t/09arrays.t"
- "t/12placeholders.t"
- "t/20savepoints.t"
- "t/30unicode.t"
- )
- if [[ ! -v DBI_DSN ]]; then
- ewarn "Functional database tests disabled due to lack of configuration."
- ewarn "Please set the following environment variables values pertaining to a"
- ewarn "pre-configured Postgres installation in order for tests to work:"
- ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
- ewarn " ( eg: dbi:Pg:dbname=testdb )"
- ewarn " DBI_USER - A Postgres Database Username"
- ewarn " DBI_PASS - A Postgres Database Password"
- ewarn ""
- ewarn "For details, visit:"
- ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
- perl_rm_files "${LIVEDB_TESTS[@]}"
- fi
-
- # Parallel testing breaks database access
- DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
-}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
index 28812ca0679e..c88b02a4e805 100644
--- a/dev-perl/DBD-Pg/Manifest
+++ b/dev-perl/DBD-Pg/Manifest
@@ -1,3 +1 @@
-DIST DBD-Pg-3.15.0.tar.gz 284379 BLAKE2B e3d8d5a2e3339c88f92dc24cca47296b8b2e597dcb81f2645180dd90b27873f209728dc0ac320e493b573c73efb54292e89370a628fc304bf319e237e04b1912 SHA512 67912da5cda42d198cdffa3f5c93267ed9da681c837fd8a9b8c6a13873a461b1123ce0a8e1f4f4398264f57ead35950b4945018e6cead14c903a809a298aecb9
-DIST DBD-Pg-3.16.3.tar.gz 287011 BLAKE2B 43e51843ccfc19d70f0cd53e00080d07257cd775469c064fe30c341cf6ca991549ea0a6d432fd2c18a21cdf47e2c9fec73b077e5cce1d4f487d883f29f20bfe0 SHA512 5f703ebc18f09eec38246955c827324111d32a10a28d311de81e804dc10c49562e93280a7fb594dd8bdb506e65c66442b7f783c5edc697cd50a18019566d96b2
DIST DBD-Pg-3.17.0.tar.gz 288633 BLAKE2B 50ac384abdf7e6d7a7e054917c319f86c874b20d87fca45dc57085c31242b99e26873aa4b7a28f4a68be88ee4af2288f505ee74051eb055359376f4395d9c908 SHA512 17e7946297c58c19aa0f069ed9e1a78022ca64f76f25d7122f08b255d5192057ccfb7ace2530b505823c540f10733c3b26c1fe24a92cee966ba724e5d1694fb1