summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-26 20:00:38 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-26 20:01:11 +1200
commit30b9f3cf88baea522fd171361d059d53c47a4635 (patch)
treefe6df5258e3e4c85dd2fe36ab472a724043ff8b6 /dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild
parentnet-analyzer/rrdtool: Add python3 support (bug #619420 by Oleg). (diff)
downloadgentoo-30b9f3cf88baea522fd171361d059d53c47a4635.tar.gz
gentoo-30b9f3cf88baea522fd171361d059d53c47a4635.tar.bz2
gentoo-30b9f3cf88baea522fd171361d059d53c47a4635.zip
dev-perl/Exporter-Tiny: Bump to version 1.0.0
- Add missing deps Upstream: - Re-package and reversion only Keywording: - Dropped amd64-fbsd mips sparc-solaris due to newdeps Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild')
-rw-r--r--dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild
new file mode 100644
index 000000000000..523eb01bfc45
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.000000
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Warnings
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"