summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-11 19:27:38 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-11 19:47:41 +0100
commite0d7b94ce878c88fd2c20ef1c7f269a222637502 (patch)
treea1195d9156ddbfee942b33935b026d4ac70b011f /dev-perl/LWP-Online/LWP-Online-1.80.0-r3.ebuild
parentdev-perl/LWP-MediaTypes: Remove old (diff)
downloadgentoo-e0d7b94ce878c88fd2c20ef1c7f269a222637502.tar.gz
gentoo-e0d7b94ce878c88fd2c20ef1c7f269a222637502.tar.bz2
gentoo-e0d7b94ce878c88fd2c20ef1c7f269a222637502.zip
dev-perl/LWP-Online: EAPI=8 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/LWP-Online/LWP-Online-1.80.0-r3.ebuild')
-rw-r--r--dev-perl/LWP-Online/LWP-Online-1.80.0-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/LWP-Online/LWP-Online-1.80.0-r3.ebuild b/dev-perl/LWP-Online/LWP-Online-1.80.0-r3.ebuild
new file mode 100644
index 000000000000..efe89905ae19
--- /dev/null
+++ b/dev-perl/LWP-Online/LWP-Online-1.80.0-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Does your process have access to the web"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+# https://rt.cpan.org/Public/Bug/Display.html?id=112728
+PATCHES=("${FILESDIR}/${DIST_VERSION}-no-network.patch")
+
+RDEPEND="
+ >=dev-perl/libwww-perl-5.805.0
+ >=dev-perl/URI-1.350.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.420.0 )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL 1\.01;/use lib q[.];\nuse inc::Module::Install::DSL 1.01;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}