summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-31 22:04:16 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-05 23:55:56 +1200
commitea28f7a90887122bca032025898aa17dd1c58de8 (patch)
tree3a07098414f16bb272a24dada56f8133c2338f69 /dev-perl/List-MoreUtils/List-MoreUtils-0.428.0.ebuild
parentnet-analyzer/tcpdump: Require USE=samba for test suite (diff)
downloadgentoo-ea28f7a90887122bca032025898aa17dd1c58de8.tar.gz
gentoo-ea28f7a90887122bca032025898aa17dd1c58de8.tar.bz2
gentoo-ea28f7a90887122bca032025898aa17dd1c58de8.zip
dev-perl/List-MoreUtils: Bump to version 0.428.0
- EAPI7 Upstream: - Fix upgrade issues on CPAN around LMU 0.416 split - Fix Pure-Perl `pairwise` to add `undef`'s to pairs when array-sizes differ. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/List-MoreUtils/List-MoreUtils-0.428.0.ebuild')
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.428.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.428.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.428.0.ebuild
new file mode 100644
index 000000000000..8b2432839806
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.428.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=0.428
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test +xs"
+RESTRICT="!test? ( test )"
+# See MoreUtils.pm/LICENSE
+LICENSE="Apache-2.0 || ( Artistic GPL-1+ )"
+
+PDEPEND="xs? ( >=dev-perl/List-MoreUtils-XS-0.426.0 )"
+RDEPEND=">=dev-perl/Exporter-Tiny-0.38.0"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Storable
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-0.426.0-xs-config.patch")
+src_configure() {
+ export LMU_USE_XS="$(usex xs 1 0)"
+ perl-module_src_configure
+}