summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Module-Pluggable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Module-Pluggable')
-rw-r--r--dev-perl/Module-Pluggable/Manifest3
-rw-r--r--dev-perl/Module-Pluggable/Module-Pluggable-4.700.0.ebuild22
-rw-r--r--dev-perl/Module-Pluggable/Module-Pluggable-4.800.0.ebuild22
-rw-r--r--dev-perl/Module-Pluggable/Module-Pluggable-5.100.0.ebuild26
-rw-r--r--dev-perl/Module-Pluggable/metadata.xml11
5 files changed, 84 insertions, 0 deletions
diff --git a/dev-perl/Module-Pluggable/Manifest b/dev-perl/Module-Pluggable/Manifest
new file mode 100644
index 000000000000..be641844982d
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Manifest
@@ -0,0 +1,3 @@
+DIST Module-Pluggable-4.7.tar.gz 26906 SHA256 f7d9ae87f37ebf12e8ff6396554fb4bcd36291c53443e3fb0904a5955cb80fb5 SHA512 cede5dbcff3dfeeaa427047f8845e11c08e08f86be534ff2af9bdd562c5ca96b41acd94960e0f9b02cf4ae1cbc38a058a174ebc8bce2d60f68f9c2aeb96af9a5 WHIRLPOOL 0a7aef7df71673d1b846ccf5c7eb8db89935ece65b1433501d15d5c8c3e76e076e12d238f9a8c69f15722d3af7d4818a96a2021cbfd9b1bd9870109b0196b24a
+DIST Module-Pluggable-4.8.tar.gz 27074 SHA256 a2b59788de632d4dfea0346d9264a007d5c3742c6055db063d400cf5acd2823d SHA512 161d7f4286907c99dc3e762aec1e0a6aec044f089896b73bb2413b015cad45da32efc4ec1ea6c5eafd8610791f80920282623fa768e80022f541d698b5d14ea7 WHIRLPOOL 6a9be74901f5ccc620e76529e4dd8f00cca92fd2d35d393cb76f1646d730583a4e629c0c8784cab3b3f5d8354d93256b4b13895b34735926ab2c60a1467ea62d
+DIST Module-Pluggable-5.1.tar.gz 29418 SHA256 e2dc354043bb16f1f3df8c4bb26070b26e594819f218cf8b8ac19e79c720916f SHA512 2ed43516ff18f50ac494f6365296f42e7dfc6704a2b01d3661ca00c295ee378184757cb03381400fba8bc5f2df06241f2ee9ecf930af4d498b042c68069a670b WHIRLPOOL f07c1ebcad473d68bd4564bcfb44b5c140bb8960e9c544f2101d967cee0c8b27e1e67e137fc2be06ae383f23170055d4a2387c6b13c5b71dc16ea5437cd526a6
diff --git a/dev-perl/Module-Pluggable/Module-Pluggable-4.700.0.ebuild b/dev-perl/Module-Pluggable/Module-Pluggable-4.700.0.ebuild
new file mode 100644
index 000000000000..8f595c82c534
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Module-Pluggable-4.700.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SIMONW
+MODULE_VERSION=4.7
+inherit perl-module
+
+DESCRIPTION="automatically give your module the ability to have plugins"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Module-Pluggable/Module-Pluggable-4.800.0.ebuild b/dev-perl/Module-Pluggable/Module-Pluggable-4.800.0.ebuild
new file mode 100644
index 000000000000..fd2864b22b85
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Module-Pluggable-4.800.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SIMONW
+MODULE_VERSION=4.8
+inherit perl-module
+
+DESCRIPTION="automatically give your module the ability to have plugins"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Module-Pluggable/Module-Pluggable-5.100.0.ebuild b/dev-perl/Module-Pluggable/Module-Pluggable-5.100.0.ebuild
new file mode 100644
index 000000000000..18475cdad81d
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Module-Pluggable-5.100.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SIMONW
+MODULE_VERSION=5.1
+inherit perl-module
+
+DESCRIPTION="Automatically give your module the ability to have plugins"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-3
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.620.0 )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Module-Pluggable/metadata.xml b/dev-perl/Module-Pluggable/metadata.xml
new file mode 100644
index 000000000000..5a08a6299f3d
--- /dev/null
+++ b/dev-perl/Module-Pluggable/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Module-Pluggable</remote-id>
+ <remote-id type="cpan-module">Devel::InnerPackage</remote-id>
+ <remote-id type="cpan-module">Module::Pluggable</remote-id>
+ <remote-id type="cpan-module">Module::Pluggable::Object</remote-id>
+ </upstream>
+</pkgmetadata>