summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-08 10:46:58 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-08 10:47:38 +1300
commitd9ba115614ecbeecb8fd940faf051359f60a144c (patch)
tree35b8bcb83b140b97646de0ecea7388fc11740dad /dev-perl/Net-Daemon
parentkde-apps/cantor: Set SRC_URI (diff)
downloadgentoo-d9ba115614ecbeecb8fd940faf051359f60a144c.tar.gz
gentoo-d9ba115614ecbeecb8fd940faf051359f60a144c.tar.bz2
gentoo-d9ba115614ecbeecb8fd940faf051359f60a144c.zip
dev-perl/Net-Daemon: Fix configfile reading bug #633722
- r1bump because this changes runtime code - will need restable because this needs testing to happen - tests restored, please do not disable them all again - EAPI6 Bug: https://bugs.gentoo.org/633722 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Net-Daemon')
-rw-r--r--dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild21
-rw-r--r--dev-perl/Net-Daemon/files/Net-Daemon-0.480.0-perl526.patch35
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild b/dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild
new file mode 100644
index 000000000000..bf39a6b8edd4
--- /dev/null
+++ b/dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MNOONING
+DIST_VERSION=0.48
+inherit perl-module
+
+DESCRIPTION="Abstract base class for portable servers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+PATCHES=(
+ "${FILESDIR}/${P}-perl526.patch"
+)
+# loop-t and loop-child-t race-condition
+# due to Net::Daemon::Test writing
+# specific files to CWD
+DIST_TEST="do"
diff --git a/dev-perl/Net-Daemon/files/Net-Daemon-0.480.0-perl526.patch b/dev-perl/Net-Daemon/files/Net-Daemon-0.480.0-perl526.patch
new file mode 100644
index 000000000000..fee09acea6cd
--- /dev/null
+++ b/dev-perl/Net-Daemon/files/Net-Daemon-0.480.0-perl526.patch
@@ -0,0 +1,35 @@
+From 08cfbdfae6e6956e1e2bbc2d0821c64daea9fd55 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 8 Oct 2017 10:17:23 +1300
+Subject: Fix ReadConfigFile implementation traversing @INC
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=123213
+Bug: https://bugs.gentoo.org/633722
+---
+ lib/Net/Daemon.pm | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/lib/Net/Daemon.pm b/lib/Net/Daemon.pm
+index fbcc9dd..6aaa151 100644
+--- a/lib/Net/Daemon.pm
++++ b/lib/Net/Daemon.pm
+@@ -29,6 +29,7 @@ use IO::Socket ();
+ use Config ();
+ use Net::Daemon::Log ();
+ use POSIX ();
++use File::Spec ();
+
+
+ package Net::Daemon;
+@@ -201,7 +202,7 @@ sub ReadConfigFile {
+ if (! -f $file) {
+ $self->Fatal("No such config file: $file");
+ }
+- my $copts = do $file;
++ my $copts = do File::Spec->rel2abs($file);
+ if ($@) {
+ $self->Fatal("Error while processing config file $file: $@");
+ }
+--
+2.14.1
+