summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-23 22:52:39 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-23 23:01:13 +0200
commit99d3a0fca8d6253d3a7738d955b41e541f22e250 (patch)
tree20815ef7bd5c0283f070643daea1eb09ce868e73 /dev-perl/Panotools-Script
parentdev-perl/Pango: EAPI=7 bump (diff)
downloadgentoo-99d3a0fca8d6253d3a7738d955b41e541f22e250.tar.gz
gentoo-99d3a0fca8d6253d3a7738d955b41e541f22e250.tar.bz2
gentoo-99d3a0fca8d6253d3a7738d955b41e541f22e250.zip
dev-perl/Panotools-Script: Version bump 0.29
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Panotools-Script')
-rw-r--r--dev-perl/Panotools-Script/Manifest1
-rw-r--r--dev-perl/Panotools-Script/Panotools-Script-0.290.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Panotools-Script/Manifest b/dev-perl/Panotools-Script/Manifest
index e634a8d1c382..923d89680cad 100644
--- a/dev-perl/Panotools-Script/Manifest
+++ b/dev-perl/Panotools-Script/Manifest
@@ -1 +1,2 @@
DIST Panotools-Script-0.28.tar.gz 158062 BLAKE2B 8131df889a344fcff745158e144905e4b644f55c4cbbd8ab92bc9c28ef870e4d0c95052aa66e1fdcace1d702b57b5b040a349adbf14622017bf1386c6c178b58 SHA512 bc63985c7412dec33ce10025e96dc7b26fe57bf2d016e7de60c082204a22681ece624054c08051c3760582386eea0954118c523db192589ace78cdf2dfacc750
+DIST Panotools-Script-0.29.tar.gz 164253 BLAKE2B cbe8c3586ecbe452e39e55acb6f90dab31760ec134c0b42251619aa461af11ccdd22966bc078e5ea6f54e70f9d0f026231fb8a96ea101d7120efa151bc941787 SHA512 780d3b03a6dd6000d8018342fc1546fdda49f79118af889f91e98b0233beb65a2d7af7679d32007656aa406d483b49b6445684bb11076ed78f8f3673298d3040
diff --git a/dev-perl/Panotools-Script/Panotools-Script-0.290.0.ebuild b/dev-perl/Panotools-Script/Panotools-Script-0.290.0.ebuild
new file mode 100644
index 000000000000..58a52a70c7cd
--- /dev/null
+++ b/dev-perl/Panotools-Script/Panotools-Script-0.290.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BPOSTLE
+DIST_VERSION=0.29
+inherit desktop perl-module
+
+DESCRIPTION="A perl module for reading, writing, and manipulating hugin script files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=virtual/perl-File-Temp-0.100.0
+ >=virtual/perl-Getopt-Long-2.0.0
+ dev-perl/URI
+ dev-perl/libwww-perl
+ >=dev-perl/Image-Size-2.900.0
+ >=media-libs/exiftool-6
+ gui? ( gnome-extra/zenity )
+"
+BDEPEND="${RDEPEND}
+"
+
+src_install() {
+ perl-module_src_install
+ if use gui ; then
+ domenu "${S}"/desktop/*.desktop || die
+ else
+ rm "${D}"/usr/bin/*-gui || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some of the scripts require 'nona', 'freepv', 'enblend', 'autotrace', and"
+ einfo "ImageMagick command-line tools which are available in the following"
+ einfo "packages: media-gfx/hugin, media-gfx/freepv, media-gfx/enblend,"
+ einfo "media-gfx/autotrace, and media-gfx/imagemagick."
+}