summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-16 15:19:39 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-16 23:49:48 +0100
commitdc5aea62337278e744f554d0097f99686e91d6da (patch)
tree393aed70bfccc859b16347b9462cf8aa9796a453 /dev-perl/Path-Class/Path-Class-0.360.0.ebuild
parentdev-perl/Parse-RecDescent: Bump to version 1.967.13 (diff)
downloadgentoo-dc5aea62337278e744f554d0097f99686e91d6da.tar.gz
gentoo-dc5aea62337278e744f554d0097f99686e91d6da.tar.bz2
gentoo-dc5aea62337278e744f554d0097f99686e91d6da.zip
dev-perl/Path-Class: Bump to version 0.360.0
- EAPI6 - Test & Dep cleanup Upstream: - Better error handling/checking - Lazier loading some dendencies - Fix weird "operation eq not found" bug - contains() fixes Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Path-Class/Path-Class-0.360.0.ebuild')
-rw-r--r--dev-perl/Path-Class/Path-Class-0.360.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Path-Class/Path-Class-0.360.0.ebuild b/dev-perl/Path-Class/Path-Class-0.360.0.ebuild
new file mode 100644
index 000000000000..cdc1a4673458
--- /dev/null
+++ b/dev-perl/Path-Class/Path-Class-0.360.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.36
+inherit perl-module
+
+DESCRIPTION="Cross-platform path specification manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ >=virtual/perl-File-Spec-3.260.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Perl-OSType
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.100
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/author-critic.t"
+ perl-module_src_test
+}