summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-09 08:27:26 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-09 08:28:09 +1300
commitd3396f0d060b6a5af05f9022990b5588b911ab79 (patch)
treeea5fd4756242cebdd9ceafe2f4d60139aea4815c /dev-perl/SOAP-Lite
parentwww-client/firefox-bin: don't hardcode 'lib/' in GTK_LIBS assignment (diff)
downloadgentoo-d3396f0d060b6a5af05f9022990b5588b911ab79.tar.gz
gentoo-d3396f0d060b6a5af05f9022990b5588b911ab79.tar.bz2
gentoo-d3396f0d060b6a5af05f9022990b5588b911ab79.zip
dev-perl/SOAP-Lite: Bump to version 1.260.0
- EAPI6 - Add USE="examples" - Cleanup author tests - Remove bogus CPAN remote-id's Upstream: - Test fixes - Use '/usr/bin/env perl' ( ugh? ) - Correct the saop namespace declaration when calling services defined in WSDL - Fix Unicode data encoding - Remove is_utf8 check - Remove use of UNIVERSAL::isa - Doc fixes Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/Manifest1
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild52
-rw-r--r--dev-perl/SOAP-Lite/metadata.xml32
3 files changed, 56 insertions, 29 deletions
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
index 41cc794d29a0..a112e6086ad8 100644
--- a/dev-perl/SOAP-Lite/Manifest
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -1 +1,2 @@
DIST SOAP-Lite-1.19.tar.gz 271044 BLAKE2B 5bdf211c0ef37089ad20c129a877b7997fa9c02539524267900c72a289e396298d253bc3d1be6e3c370c4b58cbca055a7d4a5b7ece02e2b9587d6d6019a76829 SHA512 530deba9011075b65e8eae4c64cac62c374cd17823e1d23b8383af2bc28075aa1e68809eb8b09a98b44c29cbd7398e6d24ffc9808badc39453f6b9e87a2e1a1d
+DIST SOAP-Lite-1.26.tar.gz 272187 BLAKE2B ec4519c258b2822da74c41e20dc2c0ea3242a7d1936c2e8bf637f6cfa53fc721e4864f0ca0332986f5a1c912babe522c1b409d48dc0c433abd3f85c4aa207cb6 SHA512 b09e320cecbb4859f49dcb144a446af878219f6ba3d2f7999f8656f40989d3ead0707960f561d17a9f800706fcb53020327f9c85313f6dcca34f9699a4c74143
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild
new file mode 100644
index 000000000000..bd48e266b0b5
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=1.26
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight interface to the SOAP protocol both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ >=dev-perl/XML-Parser-2.230.0
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ >=dev-perl/XML-Parser-Lite-0.715.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-kwalitee.t"
+)
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/metadata.xml b/dev-perl/SOAP-Lite/metadata.xml
index 334ddc70dd93..9d47475e554d 100644
--- a/dev-perl/SOAP-Lite/metadata.xml
+++ b/dev-perl/SOAP-Lite/metadata.xml
@@ -8,9 +8,6 @@
<upstream>
<remote-id type="cpan">SOAP-Lite</remote-id>
<remote-id type="cpan-module">Apache::SOAP</remote-id>
- <remote-id type="cpan-module">Apache::XMLRPC::Lite</remote-id>
- <remote-id type="cpan-module">LWP::Protocol</remote-id>
- <remote-id type="cpan-module">My::PingPong</remote-id>
<remote-id type="cpan-module">SOAP</remote-id>
<remote-id type="cpan-module">SOAP::Client</remote-id>
<remote-id type="cpan-module">SOAP::Cloneable</remote-id>
@@ -64,36 +61,13 @@
<remote-id type="cpan-module">SOAP::Transport::MAILTO::Client</remote-id>
<remote-id type="cpan-module">SOAP::Transport::POP3</remote-id>
<remote-id type="cpan-module">SOAP::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP::Server</remote-id>
<remote-id type="cpan-module">SOAP::Utils</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchema1999::Serializer</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchema2001::Serializer</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchema::Serializer</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchemaApacheSOAP::Deserializer</remote-id>
- <remote-id type="cpan-module">UDDI::Constants</remote-id>
- <remote-id type="cpan-module">UDDI::Data</remote-id>
- <remote-id type="cpan-module">UDDI::Deserializer</remote-id>
- <remote-id type="cpan-module">UDDI::Lite</remote-id>
- <remote-id type="cpan-module">UDDI::SOM</remote-id>
- <remote-id type="cpan-module">UDDI::Serializer</remote-id>
- <remote-id type="cpan-module">XML::Parser::Lite</remote-id>
- <remote-id type="cpan-module">XMLRPC</remote-id>
- <remote-id type="cpan-module">XMLRPC::Constants</remote-id>
- <remote-id type="cpan-module">XMLRPC::Data</remote-id>
- <remote-id type="cpan-module">XMLRPC::Deserializer</remote-id>
- <remote-id type="cpan-module">XMLRPC::Lite</remote-id>
- <remote-id type="cpan-module">XMLRPC::SOM</remote-id>
- <remote-id type="cpan-module">XMLRPC::Serializer</remote-id>
- <remote-id type="cpan-module">XMLRPC::Server</remote-id>
- <remote-id type="cpan-module">XMLRPC::Server::Parameters</remote-id>
- <remote-id type="cpan-module">XMLRPC::Test</remote-id>
- <remote-id type="cpan-module">XMLRPC::Test::Server</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Apache</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP::CGI</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Daemon</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::POP3</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::POP3::Server</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::TCP</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::TCP::Server</remote-id>
</upstream>
</pkgmetadata>