summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-01 00:28:48 +1300
committerKent Fredric <kentnl@gentoo.org>2017-04-01 00:29:06 +1300
commit37ac41a82625b51fc96839e02c3052d8d61a7f86 (patch)
tree169d78f5f955c6c2a61a3e533bfd5b2787aee320 /dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild
parentmail-client/claws-mail: add ~ppc64 keyword (bug 614064). (diff)
downloadgentoo-37ac41a82625b51fc96839e02c3052d8d61a7f86.tar.gz
gentoo-37ac41a82625b51fc96839e02c3052d8d61a7f86.tar.bz2
gentoo-37ac41a82625b51fc96839e02c3052d8d61a7f86.zip
dev-perl/Test-Deep: Bump to version 1.126.0
Upstream: - documentation improvements - more careful guard of $@ - Add control var ::LeafWrapper - Advoid relying on '.' in @INC in tests - Include stringified result of failed overloaded re match in diag - Don't warn when array_each() compares to nonref - objects on "expected" side with a 'as_test_deep_cmp' method can compare against that methods return instead of the object - class_base routine removed Bug: https://bugs.gentoo.org/614340 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild')
-rw-r--r--dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild b/dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild
new file mode 100644
index 000000000000..fe2ec999e4b5
--- /dev/null
+++ b/dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=1.126
+inherit perl-module
+
+DESCRIPTION="Extremely flexible deep comparison testing"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.90.0
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+src_test() {
+ # Bug 584238 Avoidance
+ if perl -e 'exit ( eval { require Test::Tester; Test::Tester->VERSION(0.04); 1 } ? 0 : 1 )'; then
+ perl-module_src_test
+ else
+ einfo "Test phase skipped: Test::Tester required for tests"
+ einfo "Please upgrade to >=dev-lang/perl-5.22.0 or >=virtual/perl-Test-Simple-1.1.10"
+ einfo "if you want this tested"
+ fi
+}