summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-31 13:54:26 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-31 14:00:30 +0100
commit0c8a15018fe55d5ef5c5c8ba70ded432510c2c43 (patch)
treea1033de609d0c78b0a59080a6399cda45d87fb26 /dev-perl/gtk2-trayicon/gtk2-trayicon-0.70.0.ebuild
parentdev-perl/gtk2-gladexml: Remove old (diff)
downloadgentoo-0c8a15018fe55d5ef5c5c8ba70ded432510c2c43.tar.gz
gentoo-0c8a15018fe55d5ef5c5c8ba70ded432510c2c43.tar.bz2
gentoo-0c8a15018fe55d5ef5c5c8ba70ded432510c2c43.zip
dev-perl/gtk2-trayicon: Version bump 0.07
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/gtk2-trayicon/gtk2-trayicon-0.70.0.ebuild')
-rw-r--r--dev-perl/gtk2-trayicon/gtk2-trayicon-0.70.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/gtk2-trayicon/gtk2-trayicon-0.70.0.ebuild b/dev-perl/gtk2-trayicon/gtk2-trayicon-0.70.0.ebuild
new file mode 100644
index 000000000000..2f68b6e739ff
--- /dev/null
+++ b/dev-perl/gtk2-trayicon/gtk2-trayicon-0.70.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.07
+DIST_NAME=Gtk2-TrayIcon
+DIST_EXAMPLES=("examples/*")
+inherit perl-module virtualx
+
+DESCRIPTION="Perl wrappers for the egg cup Gtk2::TrayIcon utilities"
+HOMEPAGE="http://gtk2-perl.sf.net/ https://metacpan.org/release/Gtk2-TrayIcon"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.12.0
+ >=dev-perl/Gtk2-1.12.0
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+"
+DEPEND="
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+"
+BDEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+ virtual/pkgconfig
+"
+
+src_test() {
+ virtx perl-module_src_test
+}