summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-19 10:51:45 -0400
committerBrian Evans <grknight@gentoo.org>2017-03-19 10:51:45 -0400
commit8d6aece75f1c584f09d7a84395982d0a9521f740 (patch)
tree64e6ced19881c8b1d1c174303ce291b2759b6561 /dev-php
parentdev-php/PEAR-PEAR_PackageFileManager_Plugins: Revbump to fix WORKDIR wrt bug ... (diff)
downloadgentoo-8d6aece75f1c584f09d7a84395982d0a9521f740.tar.gz
gentoo-8d6aece75f1c584f09d7a84395982d0a9521f740.tar.bz2
gentoo-8d6aece75f1c584f09d7a84395982d0a9521f740.zip
dev-php/PEAR-Text_CAPTCHA: Revbump to fix WORKDIR wrt bug 613122
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild27
-rw-r--r--dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2.ebuild47
2 files changed, 27 insertions, 47 deletions
diff --git a/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild b/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..39b7c17d0abe
--- /dev/null
+++ b/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Generation of CAPTCHAs"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="dev-php/PEAR-PEAR >=dev-lang/php-5.3:*[gd,truetype] >=dev-php/PEAR-Text_Password-1.1.1
+ !minimal? ( dev-php/PEAR-Numbers_Words
+ dev-php/PEAR-Text_Figlet
+ >=dev-php/PEAR-Image_Text-0.7.0 )"
+
+src_prepare() {
+ sed -i -e '/role="doc"/d' -e '/role="test"/d' "${WORKDIR}/package.xml" || die
+ eapply_user
+}
+
+src_install() {
+ local DOCS=( README )
+ php-pear-r2_src_install
+}
diff --git a/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2.ebuild b/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2.ebuild
deleted file mode 100644
index 5aea29b13354..000000000000
--- a/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-DESCRIPTION="Generation of CAPTCHAs"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal"
-
-RDEPEND="dev-php/PEAR-PEAR >=dev-lang/php-5.3:*[gd,truetype] >=dev-php/PEAR-Text_Password-1.1.1
- !minimal? ( dev-php/PEAR-Numbers_Words
- dev-php/PEAR-Text_Figlet
- >=dev-php/PEAR-Image_Text-0.7.0 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default_src_prepare
- sed -i -e '/role="doc"/d' -e '/role="test"/d' "${WORKDIR}/package.xml" || die
-}
-
-src_install() {
- local DOCS=( README )
- insinto /usr/share/php
- doins -r Text
- einstalldocs
-}
-
-pkg_postinst() {
- # Register the package from the package.xml file
- # Operation is not critical so die is not required
- if [[ -f "${WORKDIR}/package.xml" ]] ; then
- "${EROOT}usr/bin/peardev" install -nrO --force "${WORKDIR}/package.xml" 2> /dev/null
- fi
-}
-
-pkg_postrm() {
- # Uninstall known dependency
- "${EROOT}usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
-}