summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 14:35:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 14:36:34 +0100
commit2ac9a35628fb030f1432a071329023419b29b9c5 (patch)
treeda3a1b919b91a3c6e2f1f3998114c126b6ca7b22 /dev-python/aiofiles
parentdev-python/sphinx-autodoc-typehints: keyword ~riscv, #832066 (diff)
downloadgentoo-2ac9a35628fb030f1432a071329023419b29b9c5.tar.gz
gentoo-2ac9a35628fb030f1432a071329023419b29b9c5.tar.bz2
gentoo-2ac9a35628fb030f1432a071329023419b29b9c5.zip
dev-python/aiofiles: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiofiles')
-rw-r--r--dev-python/aiofiles/aiofiles-0.8.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/aiofiles/aiofiles-0.8.0-r1.ebuild b/dev-python/aiofiles/aiofiles-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..40c222f025e7
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-0.8.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="https://github.com/Tinche/aiofiles"
+SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest