summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-09 14:36:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-09 14:56:29 +0100
commita13e21c4ed75af032f57b6fa1f19d3363b850e84 (patch)
tree5c07584dd500fcc6fbcec0713812482ac96cdbcc /dev-python/aiostream
parentdev-python/google-api-python-client: Bump to 2.69.0 (diff)
downloadgentoo-a13e21c4ed75af032f57b6fa1f19d3363b850e84.tar.gz
gentoo-a13e21c4ed75af032f57b6fa1f19d3363b850e84.tar.bz2
gentoo-a13e21c4ed75af032f57b6fa1f19d3363b850e84.zip
dev-python/aiostream: New package, needed for vdirsyncer, v0.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest1
-rw-r--r--dev-python/aiostream/aiostream-0.4.5.ebuild37
-rw-r--r--dev-python/aiostream/metadata.xml13
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
new file mode 100644
index 000000000000..de71f8352131
--- /dev/null
+++ b/dev-python/aiostream/Manifest
@@ -0,0 +1 @@
+DIST aiostream-0.4.5.gh.tar.gz 39797 BLAKE2B 5aeb4da46158d949190af22133f1798831e14f8d8da231d3dc098caaace303061bfa49dfef1d52c533ce20201937bf5da33f36806634b2e73ccbc48c00962486 SHA512 ac1a67a6d27e18e290c5ae5b069de2e7f7205120bc747885261e23155019d5630c1f7b643df3a4fef12844d52cdfc0f1fcdcf5cb35a0061000d426c62dcffb1d
diff --git a/dev-python/aiostream/aiostream-0.4.5.ebuild b/dev-python/aiostream/aiostream-0.4.5.ebuild
new file mode 100644
index 000000000000..7e0a5fb73136
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.4.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream --cov-report html --cov-report term::' \
+ setup.cfg || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/aiostream/metadata.xml b/dev-python/aiostream/metadata.xml
new file mode 100644
index 000000000000..b33e8982719d
--- /dev/null
+++ b/dev-python/aiostream/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">vxgmichel/aiostream</remote-id>
+ <remote-id type="pypi">aiostream</remote-id>
+ </upstream>
+</pkgmetadata>