summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 09:47:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 09:55:32 +0200
commitc3768e7a05c42c525d4c6e02c41bd678b4382526 (patch)
treecc207c6b984916061075f57cb56fe859a9f0192f /dev-python/aiostream
parentdev-python/m2crypto: Enable py3.12 (diff)
downloadgentoo-c3768e7a05c42c525d4c6e02c41bd678b4382526.tar.gz
gentoo-c3768e7a05c42c525d4c6e02c41bd678b4382526.tar.bz2
gentoo-c3768e7a05c42c525d4c6e02c41bd678b4382526.zip
dev-python/aiostream: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest1
-rw-r--r--dev-python/aiostream/aiostream-0.5.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
index 8018bcc41fd5..9c90b2209360 100644
--- a/dev-python/aiostream/Manifest
+++ b/dev-python/aiostream/Manifest
@@ -1,3 +1,4 @@
DIST aiostream-0.4.5.gh.tar.gz 39797 BLAKE2B 5aeb4da46158d949190af22133f1798831e14f8d8da231d3dc098caaace303061bfa49dfef1d52c533ce20201937bf5da33f36806634b2e73ccbc48c00962486 SHA512 ac1a67a6d27e18e290c5ae5b069de2e7f7205120bc747885261e23155019d5630c1f7b643df3a4fef12844d52cdfc0f1fcdcf5cb35a0061000d426c62dcffb1d
DIST aiostream-0.5.0.gh.tar.gz 42508 BLAKE2B 44acb97c42aa7fbe56981e5d237fd28eb531e38255a3beca98f0c7fd33a019e1fa525938b6ff21d1c49df5424d1093417003bb280f6d9ee8609a0f475a347a25 SHA512 bcab27272cde42b8a09a41f9b818d8094514eeeab4b1c0304c6d2b908bcf1142d029882d51ab427b34db215dbaedf519c772be2e67a1d7f9ca5a3def0d04b7ae
DIST aiostream-0.5.1.gh.tar.gz 42439 BLAKE2B fff62e73d0da156a18ec935051e46b2ec17b36b7541db4791083bd1873f53a1ce0576a11e8ca0071bb6194312f184c4eb3cf9c5fdbd37f86768b1111edc867b5 SHA512 a93f2969a19f5e9d0ce334a54be935092b26e2b621ef3fe27bb101fa812360349c77fc9c7dc41b56491b314c236622ab812e2ee0fd9c6c136e431781b3733a75
+DIST aiostream-0.5.2.gh.tar.gz 42945 BLAKE2B 36e4f3c7834df589da3e7ec8bafb6a5b6fe40a1e868fbe0b9b81233f6721852b0e31b12144775db8785835cd5a3a0ca0a88784f7955388efd55b6ce97311b10e SHA512 282139cda0f7d08dd11af88bc3a568054906c2e0e2708f72e0ce3a67d13a44822612e3989c398ab346f8c043f17ad2e5cd2f958b1461325ad9768affec8f63fc
diff --git a/dev-python/aiostream/aiostream-0.5.2.ebuild b/dev-python/aiostream/aiostream-0.5.2.ebuild
new file mode 100644
index 000000000000..d07884312d93
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream --cov-report html --cov-report term::' \
+ setup.cfg || die
+ distutils-r1_src_prepare
+}