summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-30 23:20:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-30 23:41:48 +0200
commit83e28356081a84085624871a7bc20d5332bc2e1c (patch)
treeca5e08e27f627bcac85a8dc3eafa5f1f3f05af95 /dev-python/alembic
parentdev-python/astroid: Bump to 2.7.3 (diff)
downloadgentoo-83e28356081a84085624871a7bc20d5332bc2e1c.tar.gz
gentoo-83e28356081a84085624871a7bc20d5332bc2e1c.tar.bz2
gentoo-83e28356081a84085624871a7bc20d5332bc2e1c.zip
dev-python/alembic: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.7.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 9e9b79b59620..0ad7c5dc59c0 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.6.5.tar.gz 1174376 BLAKE2B a1bfdf611b30831363bd29a63f2a50d7c31e348ab6f450f709d1e8dbd891441263d8e0067de38c09351c26c26d07178e3079b30b5c976dfa90cd24d5973038d8 SHA512 8e5ce4bb41a47fb2c263d3542d7fd2dad04bd76b81a6a565fa93cef80a38a016944924b9eb57895ae71d7f8eef428bf440388444ef750bf281616e514a61c79b
+DIST alembic-1.7.0.tar.gz 1223858 BLAKE2B 1e0528030b153eddb2d5105d309cb611934939606cc91721e560a3fd74af76bff69ba00b0179a6d580a914634bf75f257aab094ed920298b43bbf98beec10ba6 SHA512 a2d2a6c0a6cab17bab4e66a7f8c2eff6481c0ababb836fae14d702301b1a186bf5eee84a95fcfa8501a1efaa262d61293e1dbba13b40270535068bff0449f4b5
diff --git a/dev-python/alembic/alembic-1.7.0.ebuild b/dev-python/alembic/alembic-1.7.0.ebuild
new file mode 100644
index 000000000000..08c9b69bc08a
--- /dev/null
+++ b/dev-python/alembic/alembic-1.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}