summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-02-02 13:35:12 +0000
committerMarek Szuba <marecki@gentoo.org>2024-02-02 13:35:42 +0000
commit801e1a746f1e49afea9c2ee72f823f37febb8db2 (patch)
tree9ca0563ca80a940b0ba3f2f329c550c9cf7586a7 /dev-python/ansible-compat
parentapp-editors/jedit: Stabilize 5.6.0-r1 amd64, #923569 (diff)
downloadgentoo-801e1a746f1e49afea9c2ee72f823f37febb8db2.tar.gz
gentoo-801e1a746f1e49afea9c2ee72f823f37febb8db2.tar.bz2
gentoo-801e1a746f1e49afea9c2ee72f823f37febb8db2.zip
dev-python/ansible-compat: add 4.1.11
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.11.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 1c39850134b6..4c24bb2e9715 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
DIST ansible-compat-4.1.10.tar.gz 72127 BLAKE2B 1a3c172d30a68f14a163d2ad04180856d365424b99c593933c02c83afde7008f937a86f068fd4d09741eda731a0ae9801274764e349f56fd4a64ccdf1ff831b7 SHA512 f50d07d753fa2f3985efca4aa326d3608d55b3f8d00c42c3bd9ba95c6e40c7a717160220dd602374124ebbfc94c495819b4b738cb385875033876aee458d14b4
+DIST ansible-compat-4.1.11.tar.gz 73021 BLAKE2B 4d62c6c6739ae5dcfe98347eac268f6976f12cabcf8706f89ebaed2a6750a47faaf53ce5585ee2d6a2cf8a92add9f8f74bd050e44fa6f5515a9b77a7f49979c5 SHA512 0e8de16ef0da9a036595dadbdfa5fd776f8edf0d2c16e8e2759a0e1b07f0d0fffc22a8c7be17aefb73312f3c8f56d48fdf097c527fa3b8919907923fffc44fa7
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.11.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.11.ebuild
new file mode 100644
index 000000000000..af5646e9b07f
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+)
+
+distutils_enable_tests pytest