summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-17 22:42:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-17 22:42:45 +0100
commit42da4f9a7f7a19a5302a5385bbfdba59d6a955c9 (patch)
tree5a8f0d2e1d808c090f7fa5e3efb594a2ab0b5c6e /dev-python/anyio
parentdev-python/uvicorn: Remove old (diff)
downloadgentoo-42da4f9a7f7a19a5302a5385bbfdba59d6a955c9.tar.gz
gentoo-42da4f9a7f7a19a5302a5385bbfdba59d6a955c9.tar.bz2
gentoo-42da4f9a7f7a19a5302a5385bbfdba59d6a955c9.zip
dev-python/anyio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-3.2.1.ebuild48
-rw-r--r--dev-python/anyio/files/anyio-3.2.1-missing-trio.patch125
3 files changed, 0 insertions, 174 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 854e221cc9f1..d8102ac9e4f7 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,3 +1,2 @@
-DIST anyio-3.2.1.tar.gz 126277 BLAKE2B 510980c9251081d5188f7654279753051cd9f8221f2090fb99624612e48b6f5fc1f6d9f1808f1c329c350857f14ceaee0d72615857171de33dc35cc7ba35ab23 SHA512 ef78e5531a917e3a5ddc1106f45ba556ca147e52ab29ed6cb25a3bd287148a15a015942dde6b9535d683fbe5910affed27df6ce5c4049251610f689cd151ee89
DIST anyio-3.4.0.tar.gz 135737 BLAKE2B 6023d051a10a067b8c86576dd80571a64c72a807c56235ecd7bad364b79b10c5b845c6b584c5310db01b3bfdd92deeaf64b855716b9fa817fe2fc590de33ec4c SHA512 276fb5fc243e2c7f80a069f604ef68eeaca923c0df6f533878f9bf2185e846e537a1b9a8f19260a3c9ad3aad70898884316e6783057044a936762f7eb1f1cb9a
DIST anyio-3.5.0.tar.gz 136934 BLAKE2B 422d604c23658844467926f42c09895e54debfd3ddf2f7fa561eccae0c9cbc225f51d663cb9f98a2455736ad7a81eb4ae40a6f3ad66f3d2f0b02d0a5157203e0 SHA512 b91124c95d194eb7e4542405a973895d21562a2636d9600d528465da52536d1ffedbf5a6fc3ea5b1ff3e83e7dca2b42f090bb2ff6b077e32f5a2c314f07d3206
diff --git a/dev-python/anyio/anyio-3.2.1.ebuild b/dev-python/anyio/anyio-3.2.1.ebuild
deleted file mode 100644
index 8531185549a0..000000000000
--- a/dev-python/anyio/anyio-3.2.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
-HOMEPAGE="
- https://github.com/agronholm/anyio
- https://pypi.org/project/anyio/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinx-autodoc-typehints
-
-PATCHES=(
- "${FILESDIR}"/${P}-missing-trio.patch
-)
-
-python_test() {
- distutils_install_for_testing
- epytest -Wdefault -m 'not network' -p no:django
-}
diff --git a/dev-python/anyio/files/anyio-3.2.1-missing-trio.patch b/dev-python/anyio/files/anyio-3.2.1-missing-trio.patch
deleted file mode 100644
index 492fe40fe70e..000000000000
--- a/dev-python/anyio/files/anyio-3.2.1-missing-trio.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-From d05f92bddc4b34a8d527f66d5d27513cd91c741a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 24 Jun 2021 09:16:01 +0200
-Subject: [PATCH] Handle missing trio gracefully
-
-Make it possible to use anyio without actually having to install trio.
-This involves modifying get_all_backends() to only return the backends
-that are actually present, and teaching the tests to skip trio if it
-is not importable.
----
- src/anyio/_core/_eventloop.py | 13 +++++++++----
- tests/conftest.py | 9 ++++++++-
- tests/test_pytest_plugin.py | 2 +-
- tests/test_taskgroups.py | 10 ++++++++--
- 4 files changed, 26 insertions(+), 8 deletions(-)
-
-diff --git a/src/anyio/_core/_eventloop.py b/src/anyio/_core/_eventloop.py
-index f2364a3..431a922 100644
---- a/src/anyio/_core/_eventloop.py
-+++ b/src/anyio/_core/_eventloop.py
-@@ -10,8 +10,6 @@ import sniffio
- # This must be updated when new backends are introduced
- from ._compat import DeprecatedAwaitableFloat
-
--BACKENDS = 'asyncio', 'trio'
--
- T_Retval = TypeVar('T_Retval')
- threadlocals = threading.local()
-
-@@ -106,8 +104,15 @@ def current_time() -> DeprecatedAwaitableFloat:
-
-
- def get_all_backends() -> Tuple[str, ...]:
-- """Return a tuple of the names of all built-in backends."""
-- return BACKENDS
-+ """Return a tuple of the names of all available built-in backends."""
-+ backends = ['asyncio']
-+ try:
-+ import trio
-+ except ImportError:
-+ pass
-+ else:
-+ backends.append(trio)
-+ return tuple(backends)
-
-
- def get_cancelled_exc_class() -> Type[BaseException]:
-diff --git a/tests/conftest.py b/tests/conftest.py
-index f040ac8..5834395 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -8,6 +8,11 @@ import trustme
- from _pytest.fixtures import SubRequest
- from trustme import CA
-
-+try:
-+ import trio
-+except ImportError:
-+ trio = None
-+
- uvloop_marks = []
- uvloop_policy = None
- try:
-@@ -30,7 +35,9 @@ pytest_plugins = ['pytester']
- id='asyncio'),
- pytest.param(('asyncio', {'debug': True, 'policy': uvloop_policy}), marks=uvloop_marks,
- id='asyncio+uvloop'),
-- pytest.param('trio')
-+ pytest.param('trio',
-+ marks=[pytest.mark.skipif(trio is None,
-+ reason='trio is not available')])
- ])
- def anyio_backend(request: SubRequest) -> Tuple[str, Dict[str, Any]]:
- return request.param
-diff --git a/tests/test_pytest_plugin.py b/tests/test_pytest_plugin.py
-index bb254a5..d55d511 100644
---- a/tests/test_pytest_plugin.py
-+++ b/tests/test_pytest_plugin.py
-@@ -135,7 +135,7 @@ def test_asyncio(testdir: Testdir) -> None:
- )
-
- result = testdir.runpytest('-v')
-- result.assert_outcomes(passed=2, failed=1, errors=2)
-+ result.assert_outcomes(passed=2, failed=1, errors=len(get_all_backends()))
-
-
- def test_autouse_async_fixture(testdir: Testdir) -> None:
-diff --git a/tests/test_taskgroups.py b/tests/test_taskgroups.py
-index 62a2389..47971c0 100644
---- a/tests/test_taskgroups.py
-+++ b/tests/test_taskgroups.py
-@@ -5,7 +5,6 @@ import time
- from typing import Any, AsyncGenerator, Coroutine, Dict, Generator, NoReturn, Set
-
- import pytest
--import trio
-
- import anyio
- from anyio import (
-@@ -13,6 +12,11 @@ from anyio import (
- fail_after, get_cancelled_exc_class, move_on_after, sleep, wait_all_tasks_blocked)
- from anyio.abc import TaskGroup, TaskStatus
-
-+try:
-+ import trio
-+except ImportError:
-+ trio = None
-+
- if sys.version_info < (3, 7):
- current_task = asyncio.Task.current_task
- else:
-@@ -53,7 +57,9 @@ async def test_success() -> None:
-
- @pytest.mark.parametrize('module', [
- pytest.param(asyncio, id='asyncio'),
-- pytest.param(trio, id='trio')
-+ pytest.param(trio, id='trio',
-+ marks=[pytest.mark.skipif(trio is None,
-+ reason='trio is not available')])
- ])
- def test_run_natively(module: Any) -> None:
- async def testfunc() -> None:
---
-2.32.0
-