summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-06 21:35:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-06 21:40:58 +0200
commit5ea4d5bf4b5770c4ecceb34df73b481e57d9e507 (patch)
tree2658d88b21ecf9427148ec191b04cb2dddf0ffe0 /dev-python/anyio
parentdev-python/astor: Switch to PEP517 build (diff)
downloadgentoo-5ea4d5bf4b5770c4ecceb34df73b481e57d9e507.tar.gz
gentoo-5ea4d5bf4b5770c4ecceb34df73b481e57d9e507.tar.bz2
gentoo-5ea4d5bf4b5770c4ecceb34df73b481e57d9e507.zip
dev-python/anyio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-3.4.0.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index d8102ac9e4f7..649b535674dc 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,2 +1 @@
-DIST anyio-3.4.0.tar.gz 135737 BLAKE2B 6023d051a10a067b8c86576dd80571a64c72a807c56235ecd7bad364b79b10c5b845c6b584c5310db01b3bfdd92deeaf64b855716b9fa817fe2fc590de33ec4c SHA512 276fb5fc243e2c7f80a069f604ef68eeaca923c0df6f533878f9bf2185e846e537a1b9a8f19260a3c9ad3aad70898884316e6783057044a936762f7eb1f1cb9a
DIST anyio-3.5.0.tar.gz 136934 BLAKE2B 422d604c23658844467926f42c09895e54debfd3ddf2f7fa561eccae0c9cbc225f51d663cb9f98a2455736ad7a81eb4ae40a6f3ad66f3d2f0b02d0a5157203e0 SHA512 b91124c95d194eb7e4542405a973895d21562a2636d9600d528465da52536d1ffedbf5a6fc3ea5b1ff3e83e7dca2b42f090bb2ff6b077e32f5a2c314f07d3206
diff --git a/dev-python/anyio/anyio-3.4.0.ebuild b/dev-python/anyio/anyio-3.4.0.ebuild
deleted file mode 100644
index e8baabafef7d..000000000000
--- a/dev-python/anyio/anyio-3.4.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
-HOMEPAGE="
- https://github.com/agronholm/anyio
- https://pypi.org/project/anyio/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinx-autodoc-typehints
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- distutils_install_for_testing --via-venv
- epytest -m 'not network'
-}