summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-30 07:13:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-30 07:38:58 +0100
commit8be58900919effd44489f5a250fc65dc68fb0779 (patch)
treeec0ef71a700a776e74f6588c4e796fdba406cdec /dev-python/asttokens
parentdev-python/scikit-build: Bump to 0.16.1 (diff)
downloadgentoo-8be58900919effd44489f5a250fc65dc68fb0779.tar.gz
gentoo-8be58900919effd44489f5a250fc65dc68fb0779.tar.bz2
gentoo-8be58900919effd44489f5a250fc65dc68fb0779.zip
dev-python/asttokens: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest1
-rw-r--r--dev-python/asttokens/asttokens-2.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 04edd4ac6ce2..c25b8ebb726a 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1 +1,2 @@
DIST asttokens-2.0.8.gh.tar.gz 50804 BLAKE2B 31b5fcf6c8c201279924da9297f16a1de087fe98e930dde341b54b29a54a23a462d44e1b2cc1c4695e7829b0dbb86c5a275ffac7c8430c191fd268026306c912 SHA512 e920aa50ba7f073f198182c053729e43c7cf3812a925cead258708ba88b82f6a7a32499810e67f346db79579607c07f211d924dc9e33b8bfdf44e5c9f171d53c
+DIST asttokens-2.1.0.gh.tar.gz 55584 BLAKE2B eb2a73a47fcbfe1b75e0058f7fcc650ebc3cac00e1f816d2b5b7d02b75aaa07445de854c624e3564455036e2d973bc841e9ad3c18232d88b9091cfc3a2f95c71 SHA512 f89fe2ef700c3c07f48a87e39805792d00abc1050e619a987b863f4befc186505749bde956a95eaf152c4d69e087e32f8fa997cfa5527bbeb87e0143da89a662
diff --git a/dev-python/asttokens/asttokens-2.1.0.ebuild b/dev-python/asttokens/asttokens-2.1.0.ebuild
new file mode 100644
index 000000000000..839fb416705f
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test suite itself broken with new astroid versions, upstream less care
+ # https://github.com/gristlabs/asttokens/issues/79
+ tests/test_astroid.py
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}