summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-19 13:08:50 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-19 13:09:01 -0500
commit1d56d28e26354152645d35c7741f10152fd737e9 (patch)
tree544f312e4302893a26ed284074b87409a2c8d727 /dev-python/attrs
parentmedia-libs/jbig2dec: Add patch for CVE-2016-9601, bug 607188 (diff)
downloadgentoo-1d56d28e26354152645d35c7741f10152fd737e9.tar.gz
gentoo-1d56d28e26354152645d35c7741f10152fd737e9.tar.bz2
gentoo-1d56d28e26354152645d35c7741f10152fd737e9.zip
dev-python/attrs: suppress too_slow health check on test_recurse_property
Bug: https://bugs.gentoo.org/608570 Package-Manager: Portage-2.3.3_p56, Repoman-2.3.1_p49
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/attrs-16.3.0-r1.ebuild4
-rw-r--r--dev-python/attrs/files/test_funcs-too-slow.patch21
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/attrs/attrs-16.3.0-r1.ebuild b/dev-python/attrs/attrs-16.3.0-r1.ebuild
index 3e2d8e81e60f..86b9a8ca66c0 100644
--- a/dev-python/attrs/attrs-16.3.0-r1.ebuild
+++ b/dev-python/attrs/attrs-16.3.0-r1.ebuild
@@ -29,6 +29,10 @@ DEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}"/test_funcs-too-slow.patch
+)
+
python_test() {
py.test -v -v || die
}
diff --git a/dev-python/attrs/files/test_funcs-too-slow.patch b/dev-python/attrs/files/test_funcs-too-slow.patch
new file mode 100644
index 000000000000..4d0698ed7de5
--- /dev/null
+++ b/dev-python/attrs/files/test_funcs-too-slow.patch
@@ -0,0 +1,21 @@
+diff --git a/tests/test_funcs.py b/tests/test_funcs.py
+index 36969c7..00da655 100644
+--- a/tests/test_funcs.py
++++ b/tests/test_funcs.py
+@@ -8,7 +8,7 @@ from collections import OrderedDict, Sequence, Mapping
+
+ import pytest
+
+-from hypothesis import assume, given, strategies as st
++from hypothesis import assume, given, strategies as st, settings, HealthCheck
+
+ from .utils import simple_classes, nested_classes
+
+@@ -57,6 +57,7 @@ class TestAsDict(object):
+ ), dict_factory=dict_class)
+
+ @given(nested_classes, st.sampled_from(MAPPING_TYPES))
++ @settings(suppress_health_check=[HealthCheck.too_slow])
+ def test_recurse_property(self, cls, dict_class):
+ """
+ Property tests for recursive asdict.