summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/bcrypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/bcrypt')
-rw-r--r--dev-python/bcrypt/Manifest3
-rw-r--r--dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild28
-rw-r--r--dev-python/bcrypt/bcrypt-1.1.1.ebuild39
-rw-r--r--dev-python/bcrypt/bcrypt-2.0.0.ebuild32
-rw-r--r--dev-python/bcrypt/metadata.xml10
5 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/bcrypt/Manifest b/dev-python/bcrypt/Manifest
new file mode 100644
index 000000000000..fe9089971d23
--- /dev/null
+++ b/dev-python/bcrypt/Manifest
@@ -0,0 +1,3 @@
+DIST bcrypt-1.0.2.tar.gz 39090 SHA256 03c9e8cab644dec13c94a61eccdd930c87d62363f871bfe2ee12421703f27e8b SHA512 cd27897378cf711c6dabc351e30aa063f216133af06a6f9ce63e7cc0f95e0b14cd58806cbf82ad410ca5d5a02adc43be5b76400ae353bf60520f57b76b1bf1a4 WHIRLPOOL 5c15dc34e56f6cfa64aaa30dc182837f1f7bba84906429d1ebee335d3c8d0ed146809bdf766c964e3f5d226082b79148e537b71e6a75fb5f0005178eadb31ef7
+DIST bcrypt-1.1.1.tar.gz 39714 SHA256 f68700f4560d90e30b7bb30105b9553000690222887625209aa8a14826ce0461 SHA512 b6388e69dfe4a7a40a304745607fe23fa2cd6c0f874b09c39849958f4d4c77cd5387c2baa79de69e8809c0df8841b085885c83f00bc13ee5a08b3af6c04d721f WHIRLPOOL cc5759ab03c2da11a5b2f3da741957f250eb4b016aa6e5cf3fcc3a28f527219343c321dd432235ec99fc67749edbdb6806d410d6f0ca0afad0c03374ef019b20
+DIST bcrypt-2.0.0.tar.gz 38748 SHA256 8b2d197ef220d10eb74625dde7af3b10daa973ae9a1eadd6366f763fad4387fa SHA512 61ee83c291e65307d1094d4ca80d58f823c04d8389384e33265a3d4d7537ef0846ba07e23ab1c68501851e9b9fc3cc927e0137d52450aee6af938c91c821c435 WHIRLPOOL 46484d780f50a449e5c7d40f37b20b0a9baae4b51a0facb9cb774abddba29d4353c40e274f57c101db572ba778d134d2069180ad8ee73dbef55406aee5560721
diff --git a/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild b/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..235ca139f63d
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/dstufft/bcrypt/"
+SRC_URI="https://github.com/pyca/bcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="$(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' python*)
+ !dev-python/py-bcrypt"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/bcrypt/bcrypt-1.1.1.ebuild b/dev-python/bcrypt/bcrypt-1.1.1.ebuild
new file mode 100644
index 000000000000..4f98d0f41ee6
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/pyca/bcrypt/ https://pypi.python.org/pypi/bcrypt/"
+SRC_URI="
+ https://github.com/pyca/bcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ "
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/cffi:=[${PYTHON_USEDEP}]' 'python*')
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/cffi:=[${PYTHON_USEDEP}]' 'python*')
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ !dev-python/py-bcrypt"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/bcrypt/bcrypt-2.0.0.ebuild b/dev-python/bcrypt/bcrypt-2.0.0.ebuild
new file mode 100644
index 000000000000..28ee0eeb4886
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/pyca/bcrypt/ https://pypi.python.org/pypi/bcrypt/"
+SRC_URI="
+ https://github.com/pyca/bcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ "
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ "
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ !dev-python/py-bcrypt"
+
+# The testsuite is not included in the tarball
diff --git a/dev-python/bcrypt/metadata.xml b/dev-python/bcrypt/metadata.xml
new file mode 100644
index 000000000000..23cd94387990
--- /dev/null
+++ b/dev-python/bcrypt/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="pypi">bcrypt</remote-id>
+ <remote-id type="github">pyca/bcrypt</remote-id>
+ </upstream>
+</pkgmetadata>