summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-03 07:10:04 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-03 08:22:30 +0100
commit192a609f6d0a73565d23abf980c1f087e3ffa5ca (patch)
treea4cd12470bb8c87a7208091ccf16734784710b43 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.34 (diff)
downloadgentoo-192a609f6d0a73565d23abf980c1f087e3ffa5ca.tar.gz
gentoo-192a609f6d0a73565d23abf980c1f087e3ffa5ca.tar.bz2
gentoo-192a609f6d0a73565d23abf980c1f087e3ffa5ca.zip
dev-python/boto3: Bump to 1.34.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.34.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index fe46e614089f..ac4425c71f2f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.34.30.gh.tar.gz 770197 BLAKE2B d2eabd13c0c38fddf96caed27e57c7558f56
DIST boto3-1.34.31.gh.tar.gz 770337 BLAKE2B d39a6d173fbe5ddcf305260a36d5788dd920d387e28d6f8ad32f304a2e42fce04f5527568e261bfade2a3c6dca29c1519177df1c881d59b4f88e484cd6302b9f SHA512 50828306a5da7cbdfc0a1e3028da15c6db6d54d36c1c8e641f777c6b62d4fcead9a6239c7a72667b219b3cfbc9e1008e47ee16ab60deda24cf0d88136ed52d5e
DIST boto3-1.34.32.gh.tar.gz 770755 BLAKE2B 4e2c47833d41539fb6c489ecca4d907e2ebed00e7a7ad801c839763e8001478c0be65d7db83f30b981684075549f8a2a2fce56fe6d1574ccc4d4ca2e2f46956b SHA512 33743754aed8e6bbca2fccd932719eb30065cddb57a13ff24538e539be4aaff023271a6daa7d974e3ea5048dd35734ebb04680393a7991671ef88719b94cad35
DIST boto3-1.34.33.gh.tar.gz 771413 BLAKE2B 44322f09244e39950e481737366430d31f1a12104b426d896382f12c84439412a729b6f919ac9fd66eab51b394a826a3a3f39176b9d21ab5d27d69aa9ae2df9f SHA512 8d34ff6d05bd32f10308ac0063f062376da005d7cec65842c264079fc7cc5d87807dd32140092c6147576c27d4c465f3cd8850abaf06f2c9b9ab53c21052bea5
+DIST boto3-1.34.34.gh.tar.gz 771553 BLAKE2B 52459e1baefd7986256bb6c89074aac365fb14c8fdd1b04a79bc02b6722e1e8e5f0d59b426e519947ab1795d12defbde2768af97dd3a2cdef576fdb535422567 SHA512 d0d9c47550aeb46aa3095d08583931d79fe38da8498a3ece322d7dea07b25c3569f7b44ed2afdb53cae98e4e3c337e8bb91a87c325d88798488e6ba87c73d9cb
diff --git a/dev-python/boto3/boto3-1.34.34.ebuild b/dev-python/boto3/boto3-1.34.34.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.34.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}