summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-01 06:08:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-01 07:22:14 +0200
commit010de03ab4b4bec8e8db2f0abd403442e50a46b8 (patch)
treef3cf3828079bec413c2bbfd71b6fe35779fd4de2 /dev-python/botocore
parentnet-misc/turbovnc: keyword 3.0.3 for ~x86 (diff)
downloadgentoo-010de03ab4b4bec8e8db2f0abd403442e50a46b8.tar.gz
gentoo-010de03ab4b4bec8e8db2f0abd403442e50a46b8.tar.bz2
gentoo-010de03ab4b4bec8e8db2f0abd403442e50a46b8.zip
dev-python/botocore: Bump to 1.29.165
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.165.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 0f8f125779cd..1b6af59e5896 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.29.160.gh.tar.gz 11695537 BLAKE2B e60b8ec0ea50fa13e61acd8f5cbc4f
DIST botocore-1.29.162.gh.tar.gz 11720182 BLAKE2B 38ab0a8e5c466417427d559a5646d8e2025c43f4554ca8380bd0a1d47faadddb6bc8feed297b02e3cc05f9cf9c079628b0c0a8dce4b8908dd28923de2f4e7273 SHA512 29a2882fedc63f5b59906e9648d3811c441e3901c546a8cf5a0c2079f44a82b3c1aeeaea2efbafb833748c046e749a6d1b127c2fe74d4748289228304782ef2c
DIST botocore-1.29.163.gh.tar.gz 11722194 BLAKE2B 2519b70cf7e5cba4e0544d7d1e520a499f762a78354804bc70c97177fd91eae3ce60acbaac2c0a0fdad4e99f02b85660696826b378680bc35b80ce0c6d99e254 SHA512 8ddee4f7aea1479494b0a4763d044c75bf610d0a4b52ce4a224e36c325ecb418e3560489fee56eb51428e8f0156fb171cc6af87665112d7fb787967a3499a52c
DIST botocore-1.29.164.gh.tar.gz 11728330 BLAKE2B 241747c505ae64941073de3b307829d443f79335ac2e8b756f00560b727e10d6b7ac65da92a4196ebc85fb2d266cf63a9e23fe89f3ecba8a90b13dd06a6f1a61 SHA512 181f715ea1357ed080e7bc6bfa5ea11a5a1d794721a38a32be834b703b503deae6b5bc2de25e9da541942347bbd53e4cd339eda7872e397fa90ecd0c5bdb72aa
+DIST botocore-1.29.165.gh.tar.gz 11734461 BLAKE2B 30a479dfbc1e19c08baf38e5140a542bad0dab2fa7fc141103fc08deb6f5875a96b1d2c57ee2260d29f214f98a5a3b6c22ef811164e2f0a339515979c63835b2 SHA512 5ddff691727ec26b9af5158e6547b1641f345e017c087fea9829ea8dec250da805600467b9e27ee629dcd10db71f9adb88e562c3371674f6df71401c1b72c323
diff --git a/dev-python/botocore/botocore-1.29.165.ebuild b/dev-python/botocore/botocore-1.29.165.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.165.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}