summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-20 11:19:56 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-20 11:19:56 +0200
commit4649df6c1d009d3150b8338e0644da6cbb48205d (patch)
tree71dcf6a6ed666b6a9a7daecf03bc4a6f0a501bff /dev-python/botocore
parentdev-ruby/chunky_png: add 1.3.6 (diff)
downloadgentoo-4649df6c1d009d3150b8338e0644da6cbb48205d.tar.gz
gentoo-4649df6c1d009d3150b8338e0644da6cbb48205d.tar.bz2
gentoo-4649df6c1d009d3150b8338e0644da6cbb48205d.zip
dev-python/botocore: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.4.28.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9c2995fe2ae4..7e275d3d9749 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.3.22.tar.gz 2349601 SHA256 02a6d320b09179bc5dcbafd4be732d9431bfe
DIST botocore-1.4.22.tar.gz 2495807 SHA256 9807c405e85ed5af817529b04194150cfe37277bbf6879cff1a9c9b5d75311ef SHA512 6c0c37404ef202031d336af197b1fde1434b0f8f5eda0537edc5a45a0f53ba9619443c2d6d5d31d8b0804f6c517a7b202f8af2d144e9dff159d3e43b3c395172 WHIRLPOOL 3a3f5b42c88a1663503ff9bd5f47311ec7a0b23012897b9c8dbb65ab00ae3a889babadfea04d38c34f4196124a9345cc280f44525b433e153a9e6fb3dd65e8be
DIST botocore-1.4.25.tar.gz 2498910 SHA256 1b67bb78a1ebd0ffe9daf5ee33196b7c02a196c9b46799b9a2c35237ebd77fe2 SHA512 afca40e06af741cc05a06b16ee1f4c42a6a83ef8c055e8c8caac75ab65614dd187632ca2910068ad8c528e0fd7c0c5ba02bd35b1634f6274580186c23cf15855 WHIRLPOOL f0e563bf6da5b2b879811155dfe97cc5f8a07377c2c9d4d464870beb9b2d6ab8e5c7ea8c860551756e9ce8e0f1268aa1e1e36f9d9f5a1f438086b5242f2a7689
DIST botocore-1.4.27.tar.gz 2502287 SHA256 1d18565c45ab1eeb7e5e237c7aa1ce81b6376fa63e5a9d948c5bcdfb5fe27d75 SHA512 2ce94ed553ac513db0000201620f5bb8d8af85104d2ab7b2d8d23a50ca4d01bd2c5eccae8172f379a749ca80dcb827c430412ef6ae7d73f0a2022e6119d71dc5 WHIRLPOOL 2bb20b63b38dba3c3ff28e2e5b2d927897c6ef56a4828ac496d5e3397512a7786336c7026c1c11786db8abcb93afdebe2e429c0eee3371d2041d7bc568b192e8
+DIST botocore-1.4.28.tar.gz 2503928 SHA256 145e41531a5d38862974ddf45c055e1561046f72caa04564f0435d25cf62dbe1 SHA512 51feb906bc82c66054d0b4b09041377c67839cfbe9dcf39975060b3c1acb9d8e5607fb43e93199d321ab890410550de7f7812598aeecad6709ce1317a19a3bc6 WHIRLPOOL d089d9d5a038cb8253d7a4194d66972e1ac1a0ddb92d90e3bf8a48de9c87a74ddbccef7eebe475f778ad03d6a7102c38d1905016600d51848bcef9c584136821
diff --git a/dev-python/botocore/botocore-1.4.28.ebuild b/dev-python/botocore/botocore-1.4.28.ebuild
new file mode 100644
index 000000000000..9c57e3342b4c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.4.28.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}