summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-10-26 13:15:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-10-26 13:15:04 +0700
commiteb6bf1105fd5123f3ac5d1e1b294b0bdc8835fef (patch)
tree8e6c6b169cf52810d85573042d413d5893489947 /dev-python/bpython
parentdev-ruby/rspec-mocks: add 3.11.2 (diff)
downloadgentoo-eb6bf1105fd5123f3ac5d1e1b294b0bdc8835fef.tar.gz
gentoo-eb6bf1105fd5123f3ac5d1e1b294b0bdc8835fef.tar.bz2
gentoo-eb6bf1105fd5123f3ac5d1e1b294b0bdc8835fef.zip
dev-python/bpython: add python3_11
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/bpython-0.23-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bpython/bpython-0.23-r1.ebuild b/dev-python/bpython/bpython-0.23-r1.ebuild
new file mode 100644
index 000000000000..1bcd139c79b6
--- /dev/null
+++ b/dev-python/bpython/bpython-0.23-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="
+ https://www.bpython-interpreter.org/
+ https://github.com/bpython/bpython/
+ https://pypi.org/project/bpython/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="clipboard +jedi watch"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.4.0[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
+ jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
+ watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+"
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest