summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-29 09:14:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-29 09:46:40 +0300
commit76fd021203fe6e007cb47f69ee276d64080937c5 (patch)
tree421dd2290f0f2725d7d99b15c6087632f02511d8 /dev-python/caldav
parentdev-ruby/rspec: add 3.12.0 (diff)
downloadgentoo-76fd021203fe6e007cb47f69ee276d64080937c5.tar.gz
gentoo-76fd021203fe6e007cb47f69ee276d64080937c5.tar.bz2
gentoo-76fd021203fe6e007cb47f69ee276d64080937c5.zip
dev-python/caldav: add 0.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/caldav')
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-0.10.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index c9fcc11e5abf..3636e1c04574 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1,2 +1,3 @@
+DIST caldav-0.10.gh.tar.gz 121800 BLAKE2B 6398e2e94f40e6c0d8fa757a02ae2aedcdc2bef59be9b6499a9ff86304ee2280222ff4490b9cf6fe2b37bd1e5031e17f472afbd0e42da2a82a27aec87cfecd08 SHA512 1cd98a3f59381c238ba424a30a6596e969c04bcab74cd1f9cbf9bae1da32d23b12a718135252a12fc069091994ef451bf504a05097d9539a79b397370c55609f
DIST caldav-0.9.1.gh.tar.gz 105578 BLAKE2B 3581bb0f40daf312b32ff2ef88a31502449e0727f8e6178574c5350fb0312726d62cc9e4be3b9e73b4ee55282a32fcc503da48d49c3e7f0639a96de8197e6f8b SHA512 9171a09aa81bd6ad885aaaa3dac4cb53cb05235b37aa5be72d641b1cd2ee27928213eb95358654e99adfdbf70bea4567977509f972f54b8747162e91c95e1397
DIST caldav-0.9.2.gh.tar.gz 109877 BLAKE2B a5a4a2b4a75bafbed11e91bab6e8de14863a9a9acea2ac87ac9bb3bb2b4f2bb509bb3e898b6d276af50e2863c97b1686b9dc51a3a641345501a1295b77464791 SHA512 6e325d49d8560220bf6e7c001c7ea11b0a24c0059954be6780db0a3938c48a4931b7615f576f09a8817c618c3881ada9f4a21bf2bd441326010a98066de520d6
diff --git a/dev-python/caldav/caldav-0.10.ebuild b/dev-python/caldav/caldav-0.10.ebuild
new file mode 100644
index 000000000000..121066d6ce01
--- /dev/null
+++ b/dev-python/caldav/caldav-0.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+# For now, really does use nose imports: bug #857738
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest