summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-13 21:16:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-13 21:16:45 +0300
commitb2e885eee844d2980ec4d58720197cf85f5c7e64 (patch)
tree2c3af22fa4565e162602b8ea920d0d3636e7ac2c /dev-python/cfgv
parentdev-python/editables: Stabilize 0.5 hppa, #912098 (diff)
downloadgentoo-b2e885eee844d2980ec4d58720197cf85f5c7e64.tar.gz
gentoo-b2e885eee844d2980ec4d58720197cf85f5c7e64.tar.bz2
gentoo-b2e885eee844d2980ec4d58720197cf85f5c7e64.zip
dev-python/cfgv: add 3.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cfgv')
-rw-r--r--dev-python/cfgv/Manifest1
-rw-r--r--dev-python/cfgv/cfgv-3.4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cfgv/Manifest b/dev-python/cfgv/Manifest
index ed01572398ef..ced7ab6de638 100644
--- a/dev-python/cfgv/Manifest
+++ b/dev-python/cfgv/Manifest
@@ -1 +1,2 @@
DIST cfgv-3.3.1.gh.tar.gz 10395 BLAKE2B 8727a9886334a1fe59aeb0554c4c53139ae7e1f66534102c67f005d66dc1f78cff5e5534468a10b85df645f7e8a2fc72ca6ca2e448d09cb7636d08e8b3843113 SHA512 59c358bab9f2b32a1ac6eb72bba67b76e8368e0cf78c32228a6add200a0205f698aa80d9bd1b1e8701fb699b9599c88a240f76e2c91a602a0c292a67693e6857
+DIST cfgv-3.4.0.gh.tar.gz 10334 BLAKE2B fa84c7307e32e9f19d2ec0c806afc0d54f4a5f7767d2f4f755d73bafa80425513717160e722752fb41cfbfcb8c1cb11bd363ac41e99265c19dd18166b24d6d64 SHA512 7d3939bb99bc446f30774cad8f0ddeb1ff867e63d19e4178e5c5281b8f4300c08375936170b8ab0278b040439f59d0276b0c8924f02cd410e73037fb4729af57
diff --git a/dev-python/cfgv/cfgv-3.4.0.ebuild b/dev-python/cfgv/cfgv-3.4.0.ebuild
new file mode 100644
index 000000000000..8561fd9479b4
--- /dev/null
+++ b/dev-python/cfgv/cfgv-3.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Validate configuration and produce human-readable error messages"
+HOMEPAGE="
+ https://github.com/asottile/cfgv/
+ https://pypi.org/project/cfgv/
+"
+SRC_URI="
+ https://github.com/asottile/cfgv/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest