summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-09 03:41:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-09 04:10:23 +0200
commit064c51908a5c6dd31104cb31992c7df42194e101 (patch)
tree4baf619d67ded204324c5cdf7689244bf6726581 /dev-python/cfn-lint
parentdev-python/jsonschema: Bump to 4.23.0 (diff)
downloadgentoo-064c51908a5c6dd31104cb31992c7df42194e101.tar.gz
gentoo-064c51908a5c6dd31104cb31992c7df42194e101.tar.bz2
gentoo-064c51908a5c6dd31104cb31992c7df42194e101.zip
dev-python/cfn-lint: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.5.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 2770993d9c70..8000d4689302 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -4,3 +4,4 @@ DIST cfn_lint-1.3.7.tar.gz 2469769 BLAKE2B aa059688cee5dfc35ea76a0d771e3c3d37078
DIST cfn_lint-1.4.0.tar.gz 2428307 BLAKE2B 43987652c8f12dd24f62f9122b4aebb19edd2573e01d28ba121cc3681b3e04f5a5a3c15fd70f57b6ef9b715e686d191fab0cae11554c3c185ea756d89bce624d SHA512 d07b29794443a5df7465052ab1836a67212f5b6801ba1784e054aef26c1d4f2c923aa82032f7df18b22993334e5a957f8db7d7d9aa600edab91da7d92816339b
DIST cfn_lint-1.4.2.tar.gz 2485843 BLAKE2B c2e64721b537ab38cad3c3f6d40c509741fb03f61202d7dace4023f4b5b3a7840b7deb88892d9d282d223756a1e3908680ed166cdf216b0c76abdc29d0749967 SHA512 c9761e253ba77198264eabdd9c4e6a290bb9010533628958853c8d5a0f5f7317338f271588b5cef2ac1667f6ed5e1a6e43a3192aa9ff7202b0ca6db061284818
DIST cfn_lint-1.5.0.tar.gz 2404325 BLAKE2B ba8b87334693da5b55365d47403a51922bc4230abe7b4179941c77e02cea6fff0934539cb83438830d71213ee7b8c6d73c6a49bd4ae6c2fb8093d0a2365b8aee SHA512 76513cebaf4e1d04c5846f40aca4be4ca6838c0f06948c8ce38739ef8d4b310c233f2d0a260ec7db8346ae56f0a5a0d1ab8ed618efdc4e03829840e66f3479f8
+DIST cfn_lint-1.5.1.tar.gz 2341772 BLAKE2B 00c1801a4f632febaf7a63f3a4b75b1cf21411584672096db56cfe497b83c64991aa049764e9be3bfba593d6ec8c5150f1f06e831de52df68ccc5b74fbe1cf46 SHA512 68acff7ad0532c4b3385ee620506c1391b7e9581663c04d5e763d67d265e05cf96f689dd4cfa9bfebdb0f3ac890835d02d1367900d64fa424ba7bc8bf1fb37a8
diff --git a/dev-python/cfn-lint/cfn-lint-1.5.1.ebuild b/dev-python/cfn-lint/cfn-lint-1.5.1.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.5.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}