summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 13:58:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:03 +0100
commitd0a9edd72ce2cd1c4dd7c32b7acde24c3439d028 (patch)
tree15415cb3deb82f381812ff1c83c42f2ce2c3ebb7 /dev-python/cfn-lint
parentdev-python/coverage: Bump to 7.0.3 (diff)
downloadgentoo-d0a9edd72ce2cd1c4dd7c32b7acde24c3439d028.tar.gz
gentoo-d0a9edd72ce2cd1c4dd7c32b7acde24c3439d028.tar.bz2
gentoo-d0a9edd72ce2cd1c4dd7c32b7acde24c3439d028.zip
dev-python/cfn-lint: Bump to 0.72.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index ffdcba58cd27..f1b358854711 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -2,3 +2,4 @@ DIST cfn-lint-0.71.1.gh.tar.gz 2984397 BLAKE2B faa2164ee0f469f8e9118b82d5c86dee0
DIST cfn-lint-0.72.2.gh.tar.gz 3114298 BLAKE2B 5a426a046d1a0ffb773f9b34c544ccf9f55467de156f3bc0c3324c9877a1f101da69130c39a0d0144d57557c75e9bbcecc41bb1823fe41c00f14874c516c0033 SHA512 2248e2854410ba889180dd20df1f8c1ec70150b8433a7b4d564c6d9a9c7ceaedc81bf051eeaf1906878e57dc395c5e4c08623574cb9f4dced9ea0a8fbe73325d
DIST cfn-lint-0.72.4.gh.tar.gz 3199849 BLAKE2B b0c81be6e2f21ffbc7ee4ebbfc4994d1b413516dc3a47d11f554278b33ead1d3c3c055b541e25a7401fa911c16998cf3c3c85863d2e0f295c1d3df86b78f8847 SHA512 994f418519e72e1814f2ee38e3e5a42f7e2dc1556cda5cb5632b0e57daadbad57425e14d1eff67ba39f0ca1dd22df22f43277f1b1b3d6b66679cc3526fbeedd0
DIST cfn-lint-0.72.5.gh.tar.gz 3220306 BLAKE2B 381b069e4d35d9af8fa7bab9765f3b249dc6eb114f3965e7b86fecdb2a30abd1fd4bf0c4efdc78490a9c672f6bb30093a05cf162a6f41a872d7ee93d22167aa5 SHA512 f7628894558bb3718edf6ac9f1ea27af913146d060749521900e6bd8122ddda09552dbc1a0a0f4a7c58736b7dd95a0ea8e408b798be7a06e88724e7e7d0cbed2
+DIST cfn-lint-0.72.6.gh.tar.gz 3240330 BLAKE2B f7673efbf6ce88e618e6fb1ff6e21cbb66cef2a1d9922ed90eb3556eff4f38827fce4efa799913168d60dc91929478a82644b7dcee25515172bb86ff74e33f0f SHA512 1db7bd50762c646be2f4bf3e74af8039cd593ccd9c10e68f43d3bc2e435ceb0dbbb70ac5a7cfd8408b7bc0eca2033d78d1fe3f65d0af89917684f7d44c52420b
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.6.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.6.ebuild
new file mode 100644
index 000000000000..d2f168651a4a
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.72.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.55.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}