summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-03 18:33:04 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-05 17:27:45 +0200
commit163e73d1c0e268c293333aa5691484829ed239ed (patch)
tree8ca36eed131fa340b347972e1e73f7c041f9eaf5 /dev-python/clang-python/clang-python-5.0.2.ebuild
parentsys-devel/clang: Bump to 5.0.2 (diff)
downloadgentoo-163e73d1c0e268c293333aa5691484829ed239ed.tar.gz
gentoo-163e73d1c0e268c293333aa5691484829ed239ed.tar.bz2
gentoo-163e73d1c0e268c293333aa5691484829ed239ed.zip
dev-python/clang-python: Bump to 5.0.2
Diffstat (limited to 'dev-python/clang-python/clang-python-5.0.2.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-5.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-5.0.2.ebuild b/dev-python/clang-python/clang-python-5.0.2.ebuild
new file mode 100644
index 000000000000..f60acf5217fa
--- /dev/null
+++ b/dev-python/clang-python/clang-python-5.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit python-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}/bindings/python
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
+}
+
+src_test() {
+ python_foreach_impl nosetests -v || die
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}