summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-25 07:31:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-25 10:28:02 +0200
commite10fb1ad2214dc341bf9284e60bd9e9e7d612814 (patch)
treeb2a3de0854d6cf58f7e9a4cf92c0e75140932ac5 /dev-python/colorama
parentdev-python/hypothesis: Adjust test blocker for requests-toolbelt (diff)
downloadgentoo-e10fb1ad2214dc341bf9284e60bd9e9e7d612814.tar.gz
gentoo-e10fb1ad2214dc341bf9284e60bd9e9e7d612814.tar.bz2
gentoo-e10fb1ad2214dc341bf9284e60bd9e9e7d612814.zip
dev-python/colorama: Bump to 0.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/colorama')
-rw-r--r--dev-python/colorama/Manifest1
-rw-r--r--dev-python/colorama/colorama-0.4.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
index 622ffbf04ee6..d6c1dbae9c4b 100644
--- a/dev-python/colorama/Manifest
+++ b/dev-python/colorama/Manifest
@@ -1 +1,2 @@
DIST colorama-0.4.5.gh.tar.gz 113373 BLAKE2B d7b071b1efa585c26c48f26af7a0df9bff25e3986f2615889fd25c34d785c256ac3c4655375f13e7d1bc6972f7fa64bd48a819d988160ceb75fda356d645876d SHA512 d4d3b2a4c6a0966b5c15a12cd789e4b68e5b632c4d745d93fcff5e250fe10e5d45dd2a8bd25f4399cca31a358aecf99f354aa3e1b74369ae382b51bd6c87644f
+DIST colorama-0.4.6.gh.tar.gz 116300 BLAKE2B 5b8f013a0cfa227dc750456d28af83dd6322000a3982e680d0cf051f6ae964b630f2889a0f1b78fe1cab465b25a52db07516cee9cbd99575dae38a86c5b69bd0 SHA512 2b269b190041398a1808b0b5147e47422b4451a1bc91841d0957572214ba8addd731c8932afdc60bfbba9833a0fe6c9c5c2ecb150613f13498f661799d625e4f
diff --git a/dev-python/colorama/colorama-0.4.6.ebuild b/dev-python/colorama/colorama-0.4.6.ebuild
new file mode 100644
index 000000000000..08425bfd8fbf
--- /dev/null
+++ b/dev-python/colorama/colorama-0.4.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama/
+"
+SRC_URI="
+ https://github.com/tartley/colorama/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Some tests require stdout to be a TTY
+ # https://github.com/tartley/colorama/issues/169
+ script -eqc "${EPYTHON} -m pytest -vv -s" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}