summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/d2to1
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/d2to1')
-rw-r--r--dev-python/d2to1/Manifest2
-rw-r--r--dev-python/d2to1/d2to1-0.2.11.ebuild21
-rw-r--r--dev-python/d2to1/d2to1-0.2.12.ebuild20
-rw-r--r--dev-python/d2to1/metadata.xml13
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/d2to1/Manifest b/dev-python/d2to1/Manifest
new file mode 100644
index 000000000000..72e6472cb96a
--- /dev/null
+++ b/dev-python/d2to1/Manifest
@@ -0,0 +1,2 @@
+DIST d2to1-0.2.11.tar.gz 25237 SHA256 64097a1b9270458898a0047034e9ba422a6456f51771105f33edb6b38e19bfa8 SHA512 46a8b8b154b77bbef7bfeeeba1d6752899fad1b4cac8a6df699d42c848dcccc51e16db6429d171efd829fd051215f58fd9a5ec2edb62a06cf75f00ec5faac4da WHIRLPOOL 88d71211a96523002892f8aa03abfdfd33b6859480898d8f0b68af5f1386976aa5563fbb0e15dfe588dab37d216fa74c7d990cb9ea4b61b7f53a9b8f7f5b99fe
+DIST d2to1-0.2.12.tar.gz 35901 SHA256 d75c431beb8ed9d75af35093a88218fd5fc38944ddbebff6234bea0228af43d3 SHA512 a437d3652a63267470488de677e9d9e9844265480a8693f8b0163db8e1801f123888a14b78b0efb99c88598601cda5af7cfba993bd053c0683ed9ea22e8342a6 WHIRLPOOL d27067ce3e55ba7408c08717a4a7c13e2b0e1383a3529ea95b4faf8cab74aa787648192f51179ec3bb312c9159bc0bbc93ce2befeaa709e165550392ab07767e
diff --git a/dev-python/d2to1/d2to1-0.2.11.ebuild b/dev-python/d2to1/d2to1-0.2.11.ebuild
new file mode 100644
index 000000000000..ccf82401d9d1
--- /dev/null
+++ b/dev-python/d2to1/d2to1-0.2.11.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows using distutils2-like setup.cfg files for a package metadata"
+HOMEPAGE="http://pypi.python.org/pypi/d2to1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/d2to1/d2to1-0.2.12.ebuild b/dev-python/d2to1/d2to1-0.2.12.ebuild
new file mode 100644
index 000000000000..e1768efa21b0
--- /dev/null
+++ b/dev-python/d2to1/d2to1-0.2.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows using distutils2-like setup.cfg files for a package metadata"
+HOMEPAGE="http://pypi.python.org/pypi/d2to1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/d2to1/metadata.xml b/dev-python/d2to1/metadata.xml
new file mode 100644
index 000000000000..a328208040ef
--- /dev/null
+++ b/dev-python/d2to1/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>d2to1 (the 'd' is for 'distutils') allows using distutils2-like
+ setup.cfg files for a package's metadata with a distribute/setuptools
+ setup.py script. It works by providing a distutils2-formatted setup.cfg
+ file containing all of a package's metadata, and a very minimal setup.py
+ which will slurp its arguments from the setup.cfg.</longdescription>
+ <upstream>
+ <remote-id type="pypi">d2to1</remote-id>
+ </upstream>
+</pkgmetadata>