summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-28 04:44:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-28 05:18:15 +0200
commit5d4eb77a5b6bbc7ccf826595401f54717e7eb946 (patch)
tree92a499c2572162cff852c6057cb2f1445d8f24ba /dev-python/dask
parentapp-admin/awscli: Bump to 1.29.73 (diff)
downloadgentoo-5d4eb77a5b6bbc7ccf826595401f54717e7eb946.tar.gz
gentoo-5d4eb77a5b6bbc7ccf826595401f54717e7eb946.tar.bz2
gentoo-5d4eb77a5b6bbc7ccf826595401f54717e7eb946.zip
dev-python/dask: Bump to 2023.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2023.10.1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 710e7551af2f..276fc352e7dd 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2023.10.0.gh.tar.gz 8552850 BLAKE2B 407293d4f9eb385fc244d851c71fadfe3225af7953d59f5c9a2b7f3be6ee690557c6dad828fb64f444daa14c7a7db76b3a251169c01fa0b244784c1f5177bfdc SHA512 b4006414bd8e62c443729c49c1160fe002b93703b8f2f39708e6256d0013df02a72250edd5e038abd3760a704cce5349fb8cbcd76528c6b3f24b22161be20430
+DIST dask-2023.10.1.gh.tar.gz 8557525 BLAKE2B 7516285ec942ff8daf2cb964bbb25716f60a71715ce64d40d069d25a0522a761d83d3577baf2779a9228213ea30a799c58579f5f107e82b72b863d21df84274f SHA512 bf8e23d2d1d1057941b1c50a286d51d1dc83937973c57e7af6e6e66efbf29a3c87422d6ab3b2443e264a7a40c88bdad974e71534330d7939087fbb8afed1fa45
DIST dask-2023.9.3.gh.tar.gz 8544054 BLAKE2B 4b1fc7d3b6f91fd6db0836a0fede0304e9c5e04e2aacd573eb06cf96ddf67ecbb198a185076ff94ca34216732673113e7e268482992b781777b3757d43a11773 SHA512 d91840f8a339ff0a21734726b1674c4dbc1332270fb160e01fd342b1ce1ba2fd5cea34c501c7a61e6b34e121da937701932a93ab85dc85618f5b5fc52cd960cd
diff --git a/dev-python/dask/dask-2023.10.1.ebuild b/dev-python/dask/dask-2023.10.1.ebuild
new file mode 100644
index 000000000000..68b825316221
--- /dev/null
+++ b/dev-python/dask/dask-2023.10.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ dask/tests/test_system.py::test_cpu_count_cgroups_v2
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+ # crashes
+ dask/tests/test_base.py::test_tokenize_object_with_recursion_error
+ )
+
+ if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # fails if pyarrow is installed without USE=parquet
+ # (optional dep, skipped if it's not installed at all)
+ dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_rerunfailures -m "not network" \
+ -p xdist -n "$(makeopts_jobs)"
+}