summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 18:26:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 20:29:10 -0500
commit5501fcb5b51a67497a1ded29ff82c343bbe47c0f (patch)
treee17dac096f2ec521b3cc5b1cc0799cd8c3da008a /dev-python/debtcollector/debtcollector-2.2.0.ebuild
parentdev-python/joblib: bump to 0.17.0, add Python 3.9 support (diff)
downloadgentoo-5501fcb5b51a67497a1ded29ff82c343bbe47c0f.tar.gz
gentoo-5501fcb5b51a67497a1ded29ff82c343bbe47c0f.tar.bz2
gentoo-5501fcb5b51a67497a1ded29ff82c343bbe47c0f.zip
dev-python/debtcollector: 2.2.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/debtcollector/debtcollector-2.2.0.ebuild')
-rw-r--r--dev-python/debtcollector/debtcollector-2.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/debtcollector/debtcollector-2.2.0.ebuild b/dev-python/debtcollector/debtcollector-2.2.0.ebuild
new file mode 100644
index 000000000000..e76434a9b879
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"