summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 09:15:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 09:18:38 +0100
commitf3ce6a1e488d6a1577fc6fd1a420c0701814dfe3 (patch)
tree867a007e6f650ee99bd7463e5b8239e3c9815f68 /dev-python/dict2xml
parentdev-python/noseofyeti: New package, v2.4.6 (diff)
downloadgentoo-f3ce6a1e488d6a1577fc6fd1a420c0701814dfe3.tar.gz
gentoo-f3ce6a1e488d6a1577fc6fd1a420c0701814dfe3.tar.bz2
gentoo-f3ce6a1e488d6a1577fc6fd1a420c0701814dfe3.zip
dev-python/dict2xml: Enable tests
Closes: https://bugs.gentoo.org/896390 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dict2xml')
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild b/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..116ec71f6081
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/noseofyeti[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest