summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2021-05-26 12:44:30 +0200
committerSam James <sam@gentoo.org>2021-06-01 00:27:41 +0000
commitf3526922f30a5b767c7deb9bbb1465925a909506 (patch)
treed3ba153e11f1e7bb8f6d8d232c5e3332c8e08341 /dev-python/discogs-client
parentdev-python/pipenv: drop 2020.11.4 (diff)
downloadgentoo-f3526922f30a5b767c7deb9bbb1465925a909506.tar.gz
gentoo-f3526922f30a5b767c7deb9bbb1465925a909506.tar.bz2
gentoo-f3526922f30a5b767c7deb9bbb1465925a909506.zip
dev-python/discogs-client: Version bump 2.3.12
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Closes: https://bugs.gentoo.org/790215 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/discogs-client')
-rw-r--r--dev-python/discogs-client/Manifest1
-rw-r--r--dev-python/discogs-client/discogs-client-2.3.12.ebuild41
-rw-r--r--dev-python/discogs-client/metadata.xml12
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/discogs-client/Manifest b/dev-python/discogs-client/Manifest
index df1ae110a0d7..586e6df1b821 100644
--- a/dev-python/discogs-client/Manifest
+++ b/dev-python/discogs-client/Manifest
@@ -1 +1,2 @@
DIST discogs-client-2.2.2.tar.gz 25005 BLAKE2B 1e87ce7a1cfd2d72a3dbbc0544a4e6a91d451c9d65c0712f261297e6bf4a46663bfe73d59781c9159902666cb10c0d1594a37ee6493623f794e0f4ec6ec6cfb0 SHA512 cf08526f739216efa9ef628f28650c8074cd6ddb21e0ab5431a8c8864c1f2707f612b065baf6b2f907b7fa7cdf2cfe5905cbefddb02c6f8f1c7796b0631a2ba7
+DIST discogs-client-2.3.12.tar.gz 32604 BLAKE2B 6c7960263d0158fc796edd76f6ccc549d582cbd96666cbf3ae10a3215eee6464c857e1b46c8e76ad2a48308ae9353c347a421189b3c754bd23a0f2ec455d9cfa SHA512 c14ea953e92f2d77909a7af8f840ee5a1df2416e16f6de0b7f0e988f6ef56a07fc04c75b247508dc0d1b5f7033faf6cce80196b610d1169a23350d3e816e2925
diff --git a/dev-python/discogs-client/discogs-client-2.3.12.ebuild b/dev-python/discogs-client/discogs-client-2.3.12.ebuild
new file mode 100644
index 000000000000..95c5762af1bb
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.3.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+ KEYWORDS="~amd64 ~x86"
+else
+ MY_PN='python3-discogs-client'
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="https://github.com/joalla/discogs_client https://pypi.org/project/python3-discogs-client/"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sh[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+distutils_enable_tests nose
diff --git a/dev-python/discogs-client/metadata.xml b/dev-python/discogs-client/metadata.xml
index f4f520916edb..0f66467dd020 100644
--- a/dev-python/discogs-client/metadata.xml
+++ b/dev-python/discogs-client/metadata.xml
@@ -5,8 +5,16 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
- <remote-id type="pypi">discogs-client</remote-id>
- <remote-id type="github">discogs/discogs_client</remote-id>
+ <remote-id type="pypi">python3-discogs-client</remote-id>
+ <remote-id type="github">joalla/discogs_client</remote-id>
</upstream>
</pkgmetadata>