summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-31 08:13:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-31 08:18:45 +0200
commit8faa2dd23cb515c262a98b3130d0d8879da3349d (patch)
treeb146bf4d34f784fc164795eba5ca572299e4331d /dev-python/django-cache-url
parentdev-python/sphinxcontrib-spelling: Bump to 7.5.0 (diff)
downloadgentoo-8faa2dd23cb515c262a98b3130d0d8879da3349d.tar.gz
gentoo-8faa2dd23cb515c262a98b3130d0d8879da3349d.tar.bz2
gentoo-8faa2dd23cb515c262a98b3130d0d8879da3349d.zip
dev-python/django-cache-url: Bump to 3.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cache-url')
-rw-r--r--dev-python/django-cache-url/Manifest1
-rw-r--r--dev-python/django-cache-url/django-cache-url-3.4.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-cache-url/Manifest b/dev-python/django-cache-url/Manifest
index ca57d87e53c6..c400a6047e25 100644
--- a/dev-python/django-cache-url/Manifest
+++ b/dev-python/django-cache-url/Manifest
@@ -1 +1,2 @@
DIST django-cache-url-3.4.0.tar.gz 8455 BLAKE2B 91780a053a90decbffd3d9a6fc0b9043dee74b6b6b265b9ef4b035c5679a4955582b3a3b831ff9670fceb89d5729b9ac607b6f318543d437eb35e7d1a1c1c638 SHA512 17fb8aff3b65f4860b2d2c7c765341f17c13a0f78453f627f62f40894d3e83281ecbde1d1ddcbeff7de8fe55189ce9504d03281353d227f9e7b1678af4c423ec
+DIST django-cache-url-3.4.2.gh.tar.gz 8664 BLAKE2B f97bfed1b4be0919d79304242baf7af0c092b440a1888f05c781e70cb4674a83c4f18077c1b3c9ce7dc99223ebe13527e5575af0993446d273cc387ed0e2d8d5 SHA512 7b12ff97c399cd52eef1465a504bf8edd7d422a76af5ead0157a3b52615501b7f152bf58f693255a3ccb81880123ec0efd2ec3590e07f38378e5e812c2ef3799
diff --git a/dev-python/django-cache-url/django-cache-url-3.4.2.ebuild b/dev-python/django-cache-url/django-cache-url-3.4.2.ebuild
new file mode 100644
index 000000000000..52f2bcb04312
--- /dev/null
+++ b/dev-python/django-cache-url/django-cache-url-3.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Cache URLs in your Django application"
+HOMEPAGE="
+ https://github.com/epicserve/django-cache-url/
+ https://pypi.org/project/django-cache-url/
+"
+SRC_URI="
+ https://github.com/epicserve/django-cache-url/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/--cov/d' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}