summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-05 07:18:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-05 07:21:16 +0200
commitd41485fe5a725fe9c6b5d5c6a63f470ffc42d990 (patch)
tree28e2d9d695b6068c3fb5f4f69b2e60f210878789 /dev-python/django-debug-toolbar
parentdev-python/elementpath: Bump to 4.1.2 (diff)
downloadgentoo-d41485fe5a725fe9c6b5d5c6a63f470ffc42d990.tar.gz
gentoo-d41485fe5a725fe9c6b5d5c6a63f470ffc42d990.tar.bz2
gentoo-d41485fe5a725fe9c6b5d5c6a63f470ffc42d990.zip
dev-python/django-debug-toolbar: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 65939af67ea9..a696a2a74824 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1 +1,2 @@
DIST django-debug-toolbar-3.8.1.gh.tar.gz 269449 BLAKE2B e93da38cdb6aa160dab65816858b1f7ca532ad22617e1859669fc508472086a93807aa874fde92ef95e6e33268a2f14de19d1498a15ca92ec89a9f8b3bf2a323 SHA512 4fa7b3fa3f9767cf1edba26c9de625675bcb1bafcb6d88d7ab95c331da6865f5c3cdb25848a6d2f4befdf9b2e65db4123b496f06a1b2e39eb3ee71f0c3384d26
+DIST django-debug-toolbar-4.0.0.gh.tar.gz 265429 BLAKE2B ee444246fc71bef989451bbb53e35d2be072ec9b219dfc9a9018fe736a9b750d271adc5af040374cfcb6a8e4ed26260640a952308576997e2bf42da3aec9fec4 SHA512 6a6d586a9a3c87811193c19a5fd5cb425700573a1ece71ed13d76caba208da14a1beb32e2dbc69e8ea7f09d52f42bf3b71f9608f91cc51ec41ab92558bf7e2c9
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild
new file mode 100644
index 000000000000..18838ad2c3ec
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="
+ https://github.com/jazzband/django-debug-toolbar/
+ https://pypi.org/project/django-debug-toolbar/
+"
+# no tests in sdist, as of 4.0.0
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}